Skip to content

Commit

Permalink
dev-haskell/pango: tweak for Cabal-1.24
Browse files Browse the repository at this point in the history
Use older deprecated (but still available) cabal helpers.

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/702986
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Dec 15, 2019
1 parent d417cd5 commit f2a50df
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
33 changes: 33 additions & 0 deletions dev-haskell/pango/files/pango-0.13.6.1-cabal-1.24.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
https://bugs.gentoo.org/702986

--- a/Setup.hs
+++ b/Setup.hs
@@ -8,7 +8,7 @@ import Distribution.Simple ( defaultMainWithHooks, UserHooks(postConf),
import Gtk2HsSetup ( gtk2hsUserHooks, getPkgConfigPackages)
import Distribution.Simple.Setup ( ConfigFlags(configVerbosity), fromFlag)
import Distribution.Simple.LocalBuildInfo ( LocalBuildInfo(..) )
-import Distribution.Simple.BuildPaths ( autogenPackageModulesDir )
+import Distribution.Simple.BuildPaths ( autogenModulesDir )
import Distribution.Text ( display )
import Distribution.Version ( Version(..) )
import Distribution.Verbosity
@@ -49,7 +49,7 @@ writePangoVersionHeaderFile verbosity lbi (Version (major:minor:micro:_) []) = d
, "#define PANGO_VERSION_MICRO " ++ show micro
]
where
- targetDir = autogenPackageModulesDir lbi
+ targetDir = autogenModulesDir lbi
targetFile = targetDir </> "hspangoversion.h"

writeVersionHeaderFile _ _ version =
--- a/Setup.hs
+++ b/Setup.hs
@@ -43,7 +43,7 @@ writePangoVersionHeaderFile verbosity lbi (versionNumbers -> (major:minor:micro:
writePangoVersionHeaderFile verbosity lbi (Version (major:minor:micro:_) []) = do
#endif
createDirectoryIfMissingVerbose verbosity True targetDir
- rewriteFileEx verbosity targetFile $ unlines
+ rewriteFile targetFile $ unlines
[ "#define PANGO_VERSION_MAJOR " ++ show major
, "#define PANGO_VERSION_MINOR " ++ show minor
, "#define PANGO_VERSION_MICRO " ++ show micro
2 changes: 2 additions & 0 deletions dev-haskell/pango/pango-0.13.6.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,3 +30,5 @@ DEPEND="${RDEPEND}
>=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
virtual/pkgconfig
"

PATCHES=("${FILESDIR}"/${P}-cabal-1.24.patch)

0 comments on commit f2a50df

Please sign in to comment.