Skip to content

Commit

Permalink
dev-scheme/ypsilon: fix build with GCC 11, un-last-rite
Browse files Browse the repository at this point in the history
  • Loading branch information
thesamesam committed Aug 27, 2021
1 parent db46d99 commit f36a27d
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 17 deletions.
4 changes: 2 additions & 2 deletions dev-scheme/ypsilon/files/ypsilon-0.9.6_p3-asneeded.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- ypsilon-0.9.6.update3.orig/Makefile 2008-12-23 09:56:02.000000000 +0100
+++ ypsilon-0.9.6.update3/Makefile 2009-10-21 18:14:37.613881129 +0200
--- a/Makefile
+++ b/Makefile
@@ -126,7 +126,7 @@
@mkdir -p -m755 $(HOME)/.ypsilon

Expand Down
Original file line number Diff line number Diff line change
@@ -1,14 +1,15 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

inherit epatch flag-o-matic toolchain-funcs
inherit flag-o-matic toolchain-funcs

MY_P="${P/_p/.update}"
DESCRIPTION="R6RS-compliant Scheme implementation for real-time applications"
HOMEPAGE="https://code.google.com/p/ypsilon/"
SRC_URI="https://ypsilon.googlecode.com/files/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"

LICENSE="BSD"
SLOT="0"
Expand All @@ -18,21 +19,28 @@ IUSE="examples threads"
DEPEND="app-arch/cpio"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

src_prepare() {
epatch "${FILESDIR}"/${P}-asneeded.patch
}
PATCHES=(
"${FILESDIR}"/${P}-asneeded.patch
)

src_compile() {
use threads && append-flags "-pthread"

emake PREFIX="/usr" CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}" LDFLAGS="$LDFLAGS"
# Fix build failure with GCC 11
# bug #787866
append-cppflags -DNO_TLS

emake \
PREFIX="${EPREFIX}/usr" \
CXX="$(tc-getCXX)" \
CPPFLAGS="${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS}" \
LDFLAGS="${LDFLAGS}"
}

src_install() {
emake PREFIX="/usr" DESTDIR="${D}" install
emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install

if use examples; then
insinto /usr/share/doc/${PF}/examples
doins example/*
Expand Down
5 changes: 0 additions & 5 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -156,11 +156,6 @@ app-eselect/eselect-audicle
app-eselect/eselect-miniaudicle
media-sound/audicle

# Sam James <[email protected]> (2021-08-04)
# Fails to build with GCC 11. No activity upstream since 2008.
# bug #730692, bug #787866. Removal on 2021-09-04.
dev-scheme/ypsilon

# Sam James <[email protected]> (2021-08-04)
# Fails to build with GCC 11. Library with no reverse-dependencies.
# bug #731254, bug #787905. Removal on 2021-09-04.
Expand Down

0 comments on commit f36a27d

Please sign in to comment.