Skip to content

Commit

Permalink
gnustep-libs/dbuskit: support latest gnustep-base
Browse files Browse the repository at this point in the history
Garbage collection support was dropped
Update ebuild EAPI

Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
voyageur committed Apr 25, 2017
1 parent 9cce56e commit f430a2c
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
35 changes: 35 additions & 0 deletions gnustep-libs/dbuskit/dbuskit-0.1.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools gnustep-2

DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="http://download.gna.org/gnustep/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

DEPEND=">=sys-apps/dbus-1.2.1"
RDEPEND="${DEPEND}"

PATCHES=( ${FILESDIR}/${P}-remove_gc.patch )

src_prepare() {
default

if ! use doc; then
# Remove doc target
sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
|| die "doc sed failed"
fi

# Bug 410697
sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
-i configure.ac || die "ObjectiveC2 runtime sed failed"

eautoreconf
}
29 changes: 29 additions & 0 deletions gnustep-libs/dbuskit/files/dbuskit-0.1.1-remove_gc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
--- trunk/Source/DKNotificationCenter.m 2016/03/26 05:10:00 39611
+++ trunk/Source/DKNotificationCenter.m 2016/03/28 06:16:41 39612
@@ -519,7 +519,7 @@
{
return nil;
}
- observer = GS_GC_HIDE(anObserver);
+ observer = anObserver;
selector = aSelector;

// Make sure the necessary components are there and that the selector takes a
@@ -535,7 +535,7 @@

- (id)observer
{
- return GS_GC_UNHIDE(observer);
+ return observer;
}

- (SEL)selector
@@ -561,7 +561,7 @@
// callback and need to avoid the reentrancy. We do this by scheduling
// delivery of the notification on the run loop.
[[NSRunLoop currentRunLoop] performSelector: selector
- target: GS_GC_UNHIDE(observer)
+ target: observer
argument: notification
order: UINT_MAX
modes: [NSArray arrayWithObject: NSDefaultRunLoopMode]];

0 comments on commit f430a2c

Please sign in to comment.