forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/mosquitto: Version bump to 2.0.13
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
123 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mosquitto-1.6.15.tar.gz 620117 BLAKE2B 0107ed0af902b84c73b857ccd97dfe96b1c7ed8604b843ad40f62d3f1246ded4ef1691158311ac9a672ca331f569d13547165f3a0386c77e94ddc13c8a9e3e00 SHA512 30fa2e8a15b87a33d6c8fc3a1f5d45d8e15d284fade116ac5b7bc8722609d565bed22ac592c303fc74352e3272067b2b0c8da463abffc6490cf959ce177329f3 | ||
DIST mosquitto-2.0.11.tar.gz 760325 BLAKE2B adde701bb87ec8071eaaf74fca37f81c4eae97bf98de0fe471f1dfbfb64ccda15b34611b0ffc3d2099a37994151363ad5c717bfa7695fabc1a4927ebd14ae66e SHA512 d0c7c52cb76c4711e54f841217529326d682c4decfc7a1bc96d872904e68df444ca3918fab7ba041b62f7b5420c89c631227b69a8eec51fd2e2dd480d8244710 | ||
DIST mosquitto-2.0.12.tar.gz 783859 BLAKE2B 3bac953fc7f49e19f1914186044c75d7f8b5b23e656acfb7d4c306740d0add20c08760fc206fc871c5cecf8500eb1c88acc4905bddce159d1e8f0c4e2c28b818 SHA512 acf80980f124073fd2fdd99981bde840654fb40a6b6f1d6ef483e35880b45d029cfa9390a98753de6476f4ade068266cb4c6e3c753a0362c0309a5745ac4ebab | ||
DIST mosquitto-2.0.13.tar.gz 786806 BLAKE2B 83c5c93a209225a24812c494e6065fb4ed4c65ccb34ac60918e5c32683702a9d44f162ccc366d8c2612c6fa867b56e01aaea04b2387f44b77294259198439ad0 SHA512 f22331c0a5a501b3df50b5c4788b735599024837eec4f455d422253a20e6f4ac528044ff4a7611094af87a8059e9a836157e5dc092efedf958ed7c96e5b9f9d0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,122 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{8..10} ) | ||
|
||
inherit python-any-r1 systemd toolchain-funcs | ||
|
||
DESCRIPTION="An Open Source MQTT v3 Broker" | ||
HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto" | ||
SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz" | ||
|
||
LICENSE="EPL-1.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="bridge examples +persistence +srv ssl tcpd test websockets" | ||
RESTRICT="!test? ( test )" | ||
|
||
REQUIRED_USE="test? ( bridge )" | ||
|
||
RDEPEND=" | ||
acct-user/mosquitto | ||
acct-group/mosquitto | ||
dev-libs/cJSON:= | ||
srv? ( net-dns/c-ares:= ) | ||
ssl? ( | ||
dev-libs/openssl:0= | ||
) | ||
tcpd? ( sys-apps/tcp-wrappers )" | ||
|
||
DEPEND="${PYTHON_DEPS} | ||
${RDEPEND} | ||
test? ( dev-util/cunit ) | ||
websockets? ( net-libs/libwebsockets[lejp] )" | ||
|
||
_emake() { | ||
local LIBDIR=$(get_libdir) | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
CXX="$(tc-getCXX)" \ | ||
CLIENT_LDFLAGS="${LDFLAGS}" \ | ||
LIB_SUFFIX="${LIBDIR:3}" \ | ||
WITH_BRIDGE="$(usex bridge)" \ | ||
WITH_PERSISTENCE="$(usex persistence)" \ | ||
WITH_SRV="$(usex srv)" \ | ||
WITH_TLS="$(usex ssl)" \ | ||
WITH_WEBSOCKETS="$(usex websockets)" \ | ||
WITH_WRAP="$(usex tcpd)" \ | ||
"$@" | ||
} | ||
|
||
src_prepare() { | ||
default | ||
if use persistence; then | ||
sed -i -e "/^#autosave_interval/s|^#||" \ | ||
-e "s|^#persistence false$|persistence true|" \ | ||
-e "/^#persistence_file/s|^#||" \ | ||
-e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \ | ||
mosquitto.conf || die | ||
fi | ||
|
||
# Remove prestripping | ||
sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\ | ||
client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die | ||
|
||
# Remove failing tests | ||
sed -i \ | ||
-e '/01-connect-575314.py/d' \ | ||
test/broker/Makefile || die | ||
sed -i \ | ||
-e '/02-subscribe-qos1-async2.test/d' \ | ||
test/lib/Makefile || die | ||
|
||
# Extend test timeout to prevent spurious failures | ||
sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \ | ||
test/client/test.sh || die | ||
|
||
python_setup | ||
python_fix_shebang test | ||
} | ||
|
||
src_compile() { | ||
_emake | ||
} | ||
|
||
src_test() { | ||
_emake test | ||
} | ||
|
||
src_install() { | ||
_emake DESTDIR="${D}" prefix=/usr install | ||
keepdir /var/lib/mosquitto | ||
fowners mosquitto:mosquitto /var/lib/mosquitto | ||
dodoc README.md CONTRIBUTING.md ChangeLog.txt | ||
doinitd "${FILESDIR}"/mosquitto | ||
insinto /etc/mosquitto | ||
doins mosquitto.conf | ||
insinto /usr/share/mosquitto | ||
doins misc/letsencrypt/mosquitto-copy.sh | ||
systemd_dounit "${FILESDIR}/mosquitto.service" | ||
|
||
if use examples; then | ||
docompress -x "/usr/share/doc/${PF}/examples" | ||
dodoc -r examples | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
for v in ${REPLACING_VERSIONS}; do | ||
if [[ $(ver_cut 1 "$v") -lt 2 ]]; then | ||
elog | ||
elog "Please read the migration guide at:" | ||
elog "https://mosquitto.org/documentation/migrating-to-2-0/" | ||
elog | ||
elog "If you use Lets Encrypt TLS certificates, take note of" | ||
elog "the changes required to run the daemon as the unprivileged" | ||
elog "mosquitto user. The mosquitto-copy.sh script has been" | ||
elog "installed to /usr/share/mosquitto/ for your convenience." | ||
elog | ||
fi | ||
done | ||
} |