Skip to content

Commit

Permalink
dev-libs/cdk: version bump to 5.0.20150928
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 19, 2016
1 parent 8f3dd06 commit f483df5
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/cdk/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST cdk-5.0-20131107.tgz 495455 SHA256 2b3670b95d330cce34ddd929f985c423cf86b05ba8a33bf5f217c4702131f565 SHA512 93e0c78bfd12fb9c554b9b6996b9c93542201afb67ddd63ecea7330171ca079da73d81b3f3b2f27a28ecd3527ed6c7333203a9438ecd196a66d3bad78233f439 WHIRLPOOL bedf5a441175436fb0eb54b216a61acd296d97dbbb2be1eb817b024778f58383f0ea00f6159c67c05f116f21ad6e0030a2d979aa8db2798a4f103f36f3e3198b
DIST cdk-5.0-20141106.tgz 509310 SHA256 d7ce8d9698b4998fa49a63b6e19309d3eb61cc3a019bfc95101d845ef03c4803 SHA512 8a92363c8036acb61fe8dcfcf3690653f2573407123b8c684c0bf165d5b99b6a4c7e8bcded8773304ebc13108e90ae3488f0e74ed026f3bc69f6a5b007e651e4 WHIRLPOOL d497624acb49bec7a1f18afe13c1279f5e8c06b71d4f904b88b9f639e01fae0b4d959ae90df169c477292e0f56f787944e5cffddb4416d30d85784155bde2dee
DIST cdk-5.0-20150928.tgz 515214 SHA256 028da75d5f777a1c4184f88e34918bd273bd83bbe3c959bc11710c4f0ea2e448 SHA512 5774e28d91edd477854e30eb456b7725987e82ec27f5cf055c1d1e46581e11d2958bafbac408124f274bf7454be68476d18643a265df7c74b8f43eb1895bf19d WHIRLPOOL 637cf7405139dedb82a21b3481f8673fd3c27289813e74da44afe739c258d6674fd4288f202166b9a624357ea686971010c06250f7770c2c37d538f0e7fbb12b
47 changes: 47 additions & 0 deletions dev-libs/cdk/cdk-5.0.20150928.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit versionator

MY_P="${PN}-$(replace_version_separator 2 -)"
DESCRIPTION="A library of curses widgets"
HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"

LICENSE="BSD"
SLOT="0/6" # subslot = soname version
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="examples static-libs unicode"

DEPEND=">=sys-libs/ncurses-5.2:0=[unicode?]"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}

PATCHES=( "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch )

src_configure() {
econf \
--with-libtool \
--with-shared \
--with-ncurses$(usex unicode "w" "")
}

src_install() {
# parallel make installs duplicate libs
emake -j1 \
DESTDIR="${ED}" \
DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install

if use examples ; then
for x in include c++ demos examples cli cli/utils cli/samples; do
docinto $x
find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
done
fi

use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
}

0 comments on commit f483df5

Please sign in to comment.