Skip to content

Commit

Permalink
app-admin/pdk: 1.8.0.0 initial add
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/667768
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Dec 19, 2018
1 parent 393e832 commit f4ab9e6
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/pdk/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pdk_1.8.0.0-1stretch_amd64.deb 128361866 BLAKE2B 1d21de3e011d8f111ca9910193fb2ffd3360ec1bc7d1917b89c24d42dad8c1b521b12f37850cfc88a32cc79aab76000b2801568683e96ef9aedfbe7ab48bf6b3 SHA512 edae3add1d7a0e66361cc60c555f556355a07d80dc05b21cfa8c994b8a66442168d72b602258d984f9c19c15e561c9260d3ebbc82e6bfc22758f4327d78791c2
13 changes: 13 additions & 0 deletions app-admin/pdk/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Matthew Thode</name>
</maintainer>
<longdescription lang="en">
PDK includes testing tools, a complete module skeleton, and command line
tools to help you create, validate, and run tests on Puppet modules. PDK
also includes all dependencies needed for its use.
</longdescription>
</pkgmetadata>
49 changes: 49 additions & 0 deletions app-admin/pdk/pdk-1.8.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit eutils unpacker

DESCRIPTION="Puppet SDK - develop and test puppet modules"
HOMEPAGE="https://puppetlabs.com/"
SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
SRC_URI="
amd64? ( ${SRC_BASE}_amd64.deb )
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RESTRICT="strip"

S=${WORKDIR}

QA_PREBUILT="
/opt/puppetlabs/pdk
/opt/puppetlabs/pdk/lib/engines/*
/opt/puppetlabs/pdk/lib/*
/opt/puppetlabs/pdk/bin/*"

src_install() {
# Drop the opt folder into place
insinto /opt
doins -r opt/*

# Add symlinks
chmod 0755 -R "${D}/opt/puppetlabs/pdk/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/git/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/ruby/2.1.9/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/ruby/2.4.4/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/ruby/2.5.1/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/puppet/ruby/2.1.0/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/puppet/ruby/2.4.0/bin/"
chmod 0755 -R "${D}/opt/puppetlabs/pdk/private/puppet/ruby/2.5.0/bin/"

# remove rwx a.out stuff
rm "${D}"/opt/puppetlabs/pdk/private/ruby/2.4.4/lib/ruby/gems/2.4.0/gems/ffi-1.9.25/ext/ffi_c/libffi-x86_64-linux/a.out
rm "${D}"/opt/puppetlabs/pdk/share/cache/ruby/2.1.0/gems/ffi-1.9.25/ext/ffi_c/libffi-x86_64-linux/a.out
rm "${D}"/opt/puppetlabs/pdk/share/cache/ruby/2.5.0/gems/ffi-1.9.25/ext/ffi_c/libffi-x86_64-linux/a.out

dosym ../../opt/puppetlabs/pdk/bin/pdk /usr/bin/pdk
}

0 comments on commit f4ab9e6

Please sign in to comment.