Skip to content

Commit

Permalink
app-editors/bluefish: Bump to version 2.2.9
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jul 28, 2016
1 parent 21bc9e8 commit f50a0ae
Show file tree
Hide file tree
Showing 3 changed files with 137 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/bluefish/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST bluefish-2.2.6.tar.bz2 3793018 SHA256 54c2892c317eb2287c9fb0a3e29c3f19bef51d9ab0353bfb158e52a1cdae4216 SHA512 39dee296ec6bbe1a946f9fb1c54e7143363da4bb6ce52aee14c9bef906d2eb82e5e58f78680810357c0bfcb11c21f982756a9199fec2f454c2816005a4d9d83e WHIRLPOOL b0847ea74fdc388e9ddccf1a23e8802379d149b85c5010ff9a64b3e061b0c1999e1f1a5872404b8bad2b0024fcdb09db964dae2177092d770f56aca50628d146
DIST bluefish-2.2.7.tar.bz2 3836580 SHA256 23534b73b929754e15b86d12904ca3ffc1b069da5dcd4f34a67e842fe9e858df SHA512 8b9eca746062d47d646805b02370eb9529d449d6a6a9f175353022d9df9060a9736430b6579cdd52717caab75661204e4c940c4a78fb8f6e29845e84a65395ce WHIRLPOOL 748c965da307807df6a7ebd2f430b5148bd6b8644f722d1ba5bfe70853a884eae951c35cc0c9f4a82e56b47b098fa7bd364623cc773920b08f1197852c720ee8
DIST bluefish-2.2.8.tar.bz2 4097769 SHA256 32578f955cee3f43e5b3a86e2588e6a679df94438b21dcbe38e3c82282745000 SHA512 0450909feb2370c1c84a214744f103bfe891086ba5f3ccc85060b4e134ee2161c3fde641720a3544a4d71c25f120a35925517cee4ffce6e2f07c778baa2cc5c1 WHIRLPOOL 0253e2176d68033c57db2ea1ec67c8e154722835652fe792e218a9430832ad40f67c360fc03f03e7317cda5d0fff7e83437cfd8543d58dbaf7b663ee4f68a77f
DIST bluefish-2.2.9.tar.bz2 4082978 SHA256 5b717b563325bc6c2b6cb2700323c93eb08f914f204b322241d21744a079f7d0 SHA512 ef644b37907d308b908d508ad00069e48343cd240ca7703a20b4498eda73be1a97a6c07598f6e51d4fb1c0f2a380c86a274ccbbe046da01db6c4641e41e268ae WHIRLPOOL 4e03efbc1fef3b8064e042b8532f96cafdc95ba6350b86f2b7928b93ac11bde329a16822f71bb50912c8e27a75349e8768be89e14fa5186912a5f1a13eb4d14d
107 changes: 107 additions & 0 deletions app-editors/bluefish/bluefish-2.2.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit autotools eutils fdo-mime python-single-r1

MY_P=${P/_/-}

DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
HOMEPAGE="http://bluefish.openoffice.nl/"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
IUSE="+gtk3 gucharmap nls python spell"

RDEPEND="
gnome-extra/gucharmap:2.90
sys-libs/zlib
!gtk3? ( x11-libs/gtk+:2 )
gtk3? (
x11-libs/gtk+:3
gucharmap? ( gnome-extra/gucharmap:2.90 )
)
python? ( ${PYTHON_DEPS} )
spell? ( app-text/enchant )"
DEPEND="${RDEPEND}
dev-libs/libxml2:2
>=dev-libs/glib-2.24:2
virtual/pkgconfig
x11-libs/pango
nls? (
sys-devel/gettext
dev-util/intltool
)"

S="${WORKDIR}/${MY_P}"

# there actually is just some broken manpage checkup -> not bother
RESTRICT="test"

pkg_setup() {
if ! use gtk3 && use gucharmap ; then
ewarn "gucharmap USE flag requires the gtk3 USE flag being enabled."
ewarn "Disabling charmap plugin."
fi

use python && python-single-r1_pkg_setup
}

PATCHES=(
"${FILESDIR}/${PN}-2.2.9-charmap_configure.patch"
)

# eautoreconf seems to no longer kill translation files.
src_prepare() {
default
eautoreconf
sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
}

src_configure() {
econf \
--disable-dependency-tracking \
--disable-update-databases \
--disable-xml-catalog-update \
$(use_with !gtk3 gtk2) \
$(usex gtk3 "$(use_with gucharmap charmap)" '--without-charmap') \
$(use_enable nls) \
$(use_enable spell spell-check) \
$(use_enable python)
}

src_install() {
default
prune_libtool_files
}

pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update

einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
--add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
--add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
/etc/xml/catalog \
|| ewarn "Failed to add XML catalog entries."
}

pkg_postrm() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
--del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
--del 'http://bluefish.openoffice.nl/DTD' \
/etc/xml/catalog \
|| ewarn "Failed to remove XML catalog entries."
}
29 changes: 29 additions & 0 deletions app-editors/bluefish/files/bluefish-2.2.9-charmap_configure.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
--- bluefish-2.2.9/configure.ac
+++ bluefish-2.2.9/configure.ac
@@ -504,7 +504,15 @@
AC_MSG_RESULT([no])
fi

+AC_ARG_WITH(
+ [charmap],
+ AC_HELP_STRING(
+ [--with-charmap],
+ [Build the charmap plugin if gucharmap is available @<:@default=yes@:>@]
+ )
+)

+if test "x$with_charmap" != "xno"; then
# optionally build the charmap plugin if gucharmap is available
AC_MSG_NOTICE([checking for optional libgucharmap development files])
if test "x$with_gtk3" != "xno"; then
@@ -544,6 +552,10 @@
)]
)
fi
+else
+ build_charmap_plugin=no
+ AC_MSG_WARN([Disabling the building of the charmap plugin.])
+fi
AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])

AC_SEARCH_LIBS([log10], [m])

0 comments on commit f50a0ae

Please sign in to comment.