Skip to content

Commit

Permalink
games-board/cockatrice: Version bump 20210126
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Closes: https://bugs.gentoo.org/793029
Signed-off-by: Guillaume Seren <[email protected]>
Closes: gentoo#21050
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
GuillaumeSeren authored and thesamesam committed May 31, 2021
1 parent bc37535 commit f58f22e
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/cockatrice/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cockatrice-20200823.tar.gz 8503044 BLAKE2B a987418b25db53e5fc42627e3efa93ee7348ff341d7cf844647c6655b00bb76f2929cff91c6a1d199525fba2785f4d5da533c934ad483636af1979d52f8eea94 SHA512 0fa919009536238cd540db6ef01271a41f96aa40a3d40b468fbc400905dbdfe914cfb785f62f8135355c64cc8fef19a83604aee1ad4420bb73c8f31b9d48e48b
DIST cockatrice-20210126.tar.gz 8589061 BLAKE2B f90840f2b6044ea364101410adc9481660a7247460f7191d6b022e447cc1685f28384a39596a3fbeaeb67f1af0cc184cf017f8e666e67e673672bc3968ac807a SHA512 e07cdee72c8bf4755d49cac69bd6a2ddb4c168d370ed4a1cbd341537184869ee8680fbf5e9d6b636c7c68888a8d00f474bae9cf245303d638b3aac8762f9fa8e
72 changes: 72 additions & 0 deletions games-board/cockatrice/cockatrice-20210126.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

MY_PV="2021-01-26-Release-2.8.0"
DESCRIPTION="An open-source multiplatform software for playing card games over a network"
HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
SRC_URI="https://github.com/Cockatrice/Cockatrice/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+client +oracle test server"
RESTRICT="!test? ( test )"

RDEPEND="
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5[ssl]
dev-qt/qtprintsupport:5
dev-qt/qtwebsockets:5
dev-qt/qtwidgets:5
client? (
dev-libs/protobuf:=
dev-qt/qtmultimedia:5
dev-qt/qtsvg:5
)
oracle? ( sys-libs/zlib )
server? (
dev-libs/protobuf:=
dev-qt/qtsql:5
)
"
BDEPEND="
dev-qt/linguist-tools:5
client? ( dev-libs/protobuf )
server? ( dev-libs/protobuf )
test? ( dev-cpp/gtest )
"
DEPEND="${RDEPEND}"

S="${WORKDIR}/Cockatrice-${MY_PV}"

src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DUSE_CCACHE=OFF
-DWITH_CLIENT=$(usex client)
-DWITH_ORACLE=$(usex oracle)
-DWITH_SERVER=$(usex server)
-DTEST=$(usex test)
-DICONDIR="${EPREFIX}/usr/share/icons"
-DDESKTOPDIR="${EPREFIX}/usr/share/applications" )

# Add date in the help about, come from git originally
sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${MY_PV}'\")/' \
-i cmake/getversion.cmake || die "sed failed!"

cmake_src_configure
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit f58f22e

Please sign in to comment.