Skip to content

Commit

Permalink
dev-ruby/rcairo: add 1.16.2
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
graaff committed Feb 11, 2019
1 parent 120f6cb commit f597711
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rcairo/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST cairo-1.15.10.gem 102912 BLAKE2B 55459487e9148f5b8fbdb00901cf0af9f2fd878ec0a73563e868f98aa76c517520d63702c19f10773c51545f638b7c9ccf69c1190aa324045cb82f5f93fed701 SHA512 af3cec5bf03022a5049922aaa0366b7330ec0e2003734ee855d1d9632d2027be6e08efd8b67c02bf3d006d11d8a7e28ac3d23ce9591940dc92442c7552858907
DIST cairo-1.15.11.gem 103424 BLAKE2B da4598d64d57ebe9245d892c25cfed0198d4a2c6adc440e7547314bb01adfde20118f17c6a07b0342a78c5e86b18e5c4b51782f99a61b34deeab0bdff12649ce SHA512 3c21468511eac323b27a86e1c5188b5444d3bf2de244f4dc35d0ae297cb3f1756ec8333555bb7c4178e9f4ebcfd1600e6fd77fa7fe76055bf633bb2f8c69271c
DIST cairo-1.16.2.gem 100352 BLAKE2B b8b02e949b33c60ebe05852efd1cd775a79dab5ab6837f973ecf1b2c1af653a7c09221892b92210b9e5a0d615732116a91e5e1e9f93229f98987c18b36514dcc SHA512 b711399ddd7afa958e3faee87b2a768f55af9ec0cef486d9edcf082a0c7a5ec90610d9a52784d55608a70befe4571e4cb1abc401a8a5b5357fa0bfff9159d239
78 changes: 78 additions & 0 deletions dev-ruby/rcairo/rcairo-1.16.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby23 ruby24 ruby25 ruby26"

RUBY_FAKEGEM_NAME="cairo"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"

RUBY_FAKEGEM_TASK_TEST=""

RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"

inherit multilib ruby-fakegem

DESCRIPTION="Ruby bindings for cairo"
HOMEPAGE="https://cairographics.org/rcairo/"

IUSE=""

SLOT="0"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~amd64 ~ppc ~x86"

RDEPEND="${RDEPEND}
>=x11-libs/cairo-1.2.0[svg]"
DEPEND="${DEPEND}
>=x11-libs/cairo-1.2.0[svg]"

ruby_add_bdepend "
>=dev-ruby/pkg-config-1.2.2
dev-ruby/ruby-glib2
test? ( >=dev-ruby/test-unit-2.1.0-r1:2 dev-ruby/ruby-poppler )"

all_ruby_prepare() {
# Avoid unneeded dependency
sed -i -e '/native-package-installer/ s:^:#:' ext/cairo/extconf.rb || die
sed -i -e '/native-package-installer/,/Gem::Dependency/ d' ../metadata || die

# Avoid test that requires unpackaged fixture
sed -i -e '/sub_test_case..FreeTypeFontFace/,/^ end/ s:^:#:' test/test_font_face.rb || die
}

each_ruby_configure() {
${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
}

each_ruby_compile() {
emake V=1 -Cext/cairo

# again, try to make it more standard, to install it more easily.
cp ext/cairo/cairo$(get_modname) lib/ || die
}

each_ruby_test() {
# don't rely on the Rakefile because it's a mess to load with
# their hierarchy, do it manually.
${RUBY} -Ilib -r ./test/helper \
-e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
}

each_ruby_install() {
each_fakegem_install

insinto $(ruby_get_hdrdir)
doins ext/cairo/rb_cairo.h
}

all_ruby_install() {
all_fakegem_install

insinto /usr/share/doc/${PF}/samples
doins -r samples/*
}

0 comments on commit f597711

Please sign in to comment.