Skip to content

Commit

Permalink
app-vim/gentoo-syntax: Bump to 20210428
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 28, 2021
1 parent defe1ab commit f667fb3
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/gentoo-syntax/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gentoo-syntax-20201216.tar.bz2 18631 BLAKE2B 9b68329ae2a64fba1d2a7a9fa6bb60b3a982dc2ebd5b84cf4d95052b3c8c138d7789a25c571e16cde371248e27dd8b28a7b73874749ec26e165724a43bbfaa9e SHA512 f7a6967c28aa669c8bfb114b0c60d52d970b68cd5b02a44f165f85ed5d8f42cff97ceccf4011481a84ab131c06f02725b4d9b53e3cbc0dc116dccb4ce55bd2f6
DIST gentoo-syntax-20210428.tar.bz2 18737 BLAKE2B 437bf954e2bca61e3f612761a056de3c248d8f1f7afd3d07fab01770b1ff6e0ed8adb7222a61683770f369392d2c6f52ec5594b946c9e7a69d1cc1f6033caa5b SHA512 db64f53e0c6dd0c9b7fa9142422e4b24f037e9fb012235756443556a20a2bbce9c0b712a5375f482d3caf83760bc96239afc17a1a4f2ad89e9a6166063c6af68
42 changes: 42 additions & 0 deletions app-vim/gentoo-syntax/gentoo-syntax-20210428.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit vim-plugin

DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"

LICENSE="vim"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ignore-glep31"

VIM_PLUGIN_HELPFILES="gentoo-syntax"
VIM_PLUGIN_MESSAGES="filetype"

src_prepare() {
default
if use ignore-glep31 ; then
for f in ftplugin/*.vim ; do
ebegin "Removing UTF-8 rules from ${f} ..."
sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
|| die "waah! bad sed voodoo. need more goats."
eend $?
done
fi
}

pkg_postinst() {
vim-plugin_pkg_postinst

if [[ -z ${REPLACING_VERSIONS} ]] ; then
if use ignore-glep31 1>/dev/null ; then
ewarn "You have chosen to disable the rules which ensure GLEP 31"
ewarn "compliance. When editing ebuilds, please make sure you get"
ewarn "the character set correct."
fi
fi
}

0 comments on commit f667fb3

Please sign in to comment.