Skip to content

Commit

Permalink
media-libs/dav1d: Version bump to 0.5.1, move to EAPI=7
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
patrick-mclean authored and chutz committed Oct 28, 2019
1 parent dcfeb16 commit f6964fc
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/dav1d/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST dav1d-0.2.1.tar.bz2 412003 BLAKE2B 51520f355f51f7fdc8c6e7981fd29f8d5339c2c7
DIST dav1d-0.3.0.tar.bz2 435690 BLAKE2B 57124b2a5bcde8a2de8e4ee8155ec736d2f4c13dc7347029c517d70495de1943feef7f0c7ce1d1051304fe9f3141775fbe07ceec0733fdca3dca166cbab6c417 SHA512 bc0933bbc7064555e8973c82390e414aca8f52a14c5de7ee3ff92c263722d5c9cc472ba5f1f8d1dd60c4ce9ab0ed880c8b4a53b3d33d3aff24bc8e7fb18b0b84
DIST dav1d-0.3.1.tar.bz2 438676 BLAKE2B f51c997fb95abc5b2721d67feb2023daf6bdab8d725b2b52b6c25440dcfab637b8543b8622c18da678eff20bbed155e86da9c9040a98160e5b9381ba7ab5ecf8 SHA512 b810c993a2a262f75ea0d4404428bc5660ac0d4c4d41aa311bc2180abecc40b36e73858f436b27372f4a1a0b7c700df4f8cc535130c663d6bfba2206d549e0f2
DIST dav1d-0.4.0.tar.bz2 493854 BLAKE2B 8ae022054ab9827306f6e8501e0bfbc03a04e280a3e155c12ae2dfef474eab976097ce3ed990bd5cdbc3ac79018138a156f0701973ac40357224feb75149332a SHA512 7d2ad9959649321e86f9d0dcf44b274251c103fce9f02964d898b6d9da69e38e93bbed86a7ea217c93e0ee89e1ad43bc31dc217535c4b1cc37761191a6585fc1
DIST dav1d-0.5.1.tar.bz2 548584 BLAKE2B 407188a57c469124db4863bc78dbca8b31879ed8836503ba584d4781e5f956c9f0a4661a4f47729bde74f1dd393c08db98a4cb49103f99c0f76720bc148b53a9 SHA512 2d1e7888fa9c138903b4209647e907803d2444fc2afb219b9a45dcc4c75098128b299950750bd68970004ea413ad88933d4d651a3e4e0e1557506598a15cee3b
56 changes: 56 additions & 0 deletions media-libs/dav1d/dav1d-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

SCM=""
if [[ "${PV}" == "9999" ]]; then
SCM="git-r3"
EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
else
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
fi

inherit ${SCM} meson ninja-utils multilib-minimal

DESCRIPTION="dav1d is an AV1 Decoder :)"
HOMEPAGE="https://code.videolan.org/videolan/dav1d"

LICENSE="BSD-2"
SLOT="0/3"
IUSE="+8bit +10bit +asm"

ASM_DEPEND=">=dev-lang/nasm-2.13.02"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
)"

DOCS=( README.md doc/PATENTS THANKS.md )

multilib_src_configure() {
local -a bits=()
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )

if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
build_asm=false
else
build_asm=$(usex asm true false)
fi

local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D build_asm=$build_asm
)
meson_src_configure
}

multilib_src_compile() {
eninja
}

multilib_src_install() {
DESTDIR="${D}" eninja install
}

0 comments on commit f6964fc

Please sign in to comment.