Skip to content

Commit

Permalink
dev-util/ctags: version bump.
Browse files Browse the repository at this point in the history
Courtesy of [email protected].

Gentoo-Bug: https://bugs.gentoo.org/624032

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
monsieurp committed Jul 20, 2017
1 parent 5ae8051 commit f6e8c8a
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/ctags/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST ctags-20161028.tar.xz 852108 SHA256 8c10b3728ed90793fa25e5225e8cf56ee0a01b5da6d2bcdccd97e8ec0db2da4e SHA512 2b991ca47fc77d26da43f55753624d1b21363dbeec4aff3daa57762ff81df97b18b067e8989f5d92d36dd8c02abc04ad42296dd5da3659ae0c8901001287c75e WHIRLPOOL ac8b51f9d453c7d5ae52044d711949112f0523c61c5de12827188c694f616c5108ff4af86e2b810da859b88ba9ada1a9f9d36ba52060ebb16ed570f185caea95
DIST ctags-20170704.zip 2522952 SHA256 94d21334e4f814a30338bca90a207da5c4c3b4dc75ea757daae0da366276b6af SHA512 d44ef77d81fcfcaf72754df8ab00c1385bad0186c5af0c9385521b9716ef1c3730e13a7e0b52f2ffd3cc30dde236d2417a74296e63cf1ecf2832acb6f0af2f4e WHIRLPOOL e495b8540c0ba6b5d686f09695bcfef05da898099510f6deb64995f13bc8ab4fe943c2cdc83dc89dcca05e4d51a87467d9d805aaa7566b61b6769a48d26a7de9
DIST ctags-5.8.tar.gz 479927 SHA256 0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7 SHA512 981912cd335978cde22864e977947fc75326572fb29518e559cc4a8ac1edc84b3604165218a666e36353f17da4f89f8e967acdb88696f816748eb946d79eaa15 WHIRLPOOL 04506a4495025907ee5fe41b9c4ff104dd234fc9ef39bd594158b36c550bf511b6ab5980a98736f9857dc47b99f1718a7ae2928fd4a1d1c0b57dfd3d79fce2ea
DIST ctags-5.8_p20140919.tar.gz 582289 SHA256 eebc85bd0206988250d9b24a7d02918bbca751259b086d5f53f31b4b39f571ee SHA512 3b6ad6e2d1f683dffe9e79c607f9cc222c4aa3c1f5113540cd18ea66d8f862917c9d849ee81d8b33a57ddd09749fa28fde74868d48479269a6e17b6c0451342d WHIRLPOOL 0c4008e914aed33097641fbb517f33e2ccf771a968ae3d1f6288422cdb634dda054ece11dd6204d624c9c78d4a36cecc4bb9d696d07f2bba24f3099aa3758f48
DIST ctags-ada-mode-4.3.11.tar.bz2 14060 SHA256 d25a3fd26b356adbd068f10a0b68691d36c154c04b96304b96386e169e4b6b57 SHA512 51c71e13ef658cd6682f04c94485315c4a702080ef2c7786fc9881b03c86f1c1d43aa1a69c452e4b0b2f7a78383804b66b159542cb4eae0cd309bc1ddbe2eb6e WHIRLPOOL 7e0ded8c97d3651e1afe48ec836697a4a19264baf3b203f6e98c134b88e3ab0eee7ac660789f5b955f0f827128996988694aa6c4bc78f18adf52724c5230da5d
75 changes: 75 additions & 0 deletions dev-util/ctags/ctags-20170704.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

COMMITHASH="0645b2c833e4ca956970cc96fab32a1b04c0c55c"

DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
SRC_URI="https://github.com/universal-ctags/ctags/archive/${COMMITHASH}.zip -> ${P}.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="json xml yaml"

CDEPEND="
json? ( dev-libs/jansson )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"

RDEPEND="
${CDEPEND}
app-eselect/eselect-ctags
"

DEPEND="
${CDEPEND}
dev-python/docutils
virtual/pkgconfig
app-arch/unzip
"

S="${WORKDIR}/${PN}-${COMMITHASH}"

src_prepare() {
default
./misc/dist-test-cases > makefiles/test-cases.mak || die
eautoreconf
}

src_configure() {
econf \
$(use_enable json) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-readlib \
--disable-etags \
--enable-tmpdir="${EPREFIX}"/tmp
}

src_install() {
emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install

# namepace collision with X/Emacs-provided /usr/bin/ctags -- we
# rename ctags to exuberant-ctags (Mandrake does this also).
mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
}

pkg_postinst() {
eselect ctags update

if [[ -z "$REPLACING_VERSIONS" ]]; then
elog "You can set the version to be started by /usr/bin/ctags through"
elog "the ctags eselect module. \"man ctags.eselect\" for details."
fi
}

pkg_postrm() {
eselect ctags update
}

0 comments on commit f6e8c8a

Please sign in to comment.