Skip to content

Commit

Permalink
sci-electronics/puff: Minor maintenance release
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Thomas Beierlein <[email protected]>
  • Loading branch information
dl1jbe committed Jun 29, 2021
1 parent c13c781 commit f7152b3
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-electronics/puff/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST puff-20100127.tgz 430028 BLAKE2B e3c019c4034f4f70c3f1a2468360a8838ee338ec167b8da9ef6ec630d6443c66e798e22e6e2b80f6d706191756831aa3fa5146170e0bdb2cebe3cfcf13f6cd99 SHA512 d39d74300a5f6d226dcd6147f3c63cf30396abd14d765b24b48dbd1956c81a10d4233c141789648423aa44631197e1ec160630f9b20b6ac5ae641ae67cdcb2da
DIST puff-20181104.tgz 430096 BLAKE2B f87bd2d93ff83271fbac9b2933b87dbbd47aa032e5662a77d77e58563a1e353b302f295520895b1a705c28a146ebf080fc5b66d17737a7c1d6fa48d320d3fb70 SHA512 44ffc132f2ecf92868129a98ae9d154a62232c670bfd139de6bee7f03c2ad3531068f8738f26a0074d169097945436e4630bf795c006354f335d41efa5aaa881
47 changes: 47 additions & 0 deletions sci-electronics/puff/puff-20181104.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic

DESCRIPTION="microwave CAD software"
HOMEPAGE="https://wwwhome.cs.utwente.nl/~ptdeboer/ham/puff/"
SRC_URI="https://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
dev-lang/fpc"

src_prepare() {
default
# fix lib path for X11 and dont ignore LDFLAGS
sed -i -e 's/CFLAGS/#CFLAGS/' \
-e 's/link.res/.res/g' \
-e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
}

src_compile() {
LDFLAGS="$(raw-ldflags)"
emake -j1
}

src_install() {
dobin puff

dodoc changelog.txt README.txt
newdoc "Puff Manual.pdf" Puff_Manual.pdf

insinto /usr/share/${PN}
doins setup.puf
doins -r orig_dev_and_puf_files
}

pkg_postinst() {
elog "You must copy /usr/share/${PN}/setup.puf into your working directory"
elog "before using the program."
}

0 comments on commit f7152b3

Please sign in to comment.