forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-pda/libimobiledevice: Fix for slibtool
Thanks-to: orbea <[email protected]> Closes: https://bugs.gentoo.org/780657 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
May 3, 2021
1 parent
fdc6097
commit f7a15c5
Showing
2 changed files
with
107 additions
and
0 deletions.
There are no files selected for viewing
105 changes: 105 additions & 0 deletions
105
app-pda/libimobiledevice/files/libimobiledevice-1.3.0-slibtool.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
From 735ac51e0eeaa3419e85dbad9579401ae828f631 Mon Sep 17 00:00:00 2001 | ||
From: orbea <[email protected]> | ||
Date: Tue, 6 Apr 2021 13:06:35 -0700 | ||
Subject: [PATCH] tools: Fix usage of LDFLAGS and LDADD. | ||
|
||
Signed-off-by: orbea <[email protected]> | ||
--- | ||
tools/Makefile.am | 40 ++++++++++++++++++++-------------------- | ||
1 file changed, 20 insertions(+), 20 deletions(-) | ||
|
||
diff --git a/tools/Makefile.am b/tools/Makefile.am | ||
index 8ed8ad91..04a5faa7 100644 | ||
--- a/tools/Makefile.am | ||
+++ b/tools/Makefile.am | ||
@@ -40,8 +40,8 @@ bin_PROGRAMS = \ | ||
|
||
ideviceinfo_SOURCES = ideviceinfo.c | ||
ideviceinfo_CFLAGS = $(AM_CFLAGS) | ||
-ideviceinfo_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-ideviceinfo_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+ideviceinfo_LDFLAGS = $(AM_LDFLAGS) | ||
+ideviceinfo_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicename_SOURCES = idevicename.c | ||
idevicename_CFLAGS = $(AM_CFLAGS) | ||
@@ -50,8 +50,8 @@ idevicename_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
|
||
idevicepair_SOURCES = idevicepair.c | ||
idevicepair_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS) | ||
-idevicepair_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) $(libusbmuxd_LIBS) | ||
-idevicepair_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicepair_LDFLAGS = $(AM_LDFLAGS) $(libusbmuxd_LIBS) | ||
+idevicepair_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicesyslog_SOURCES = idevicesyslog.c | ||
idevicesyslog_CFLAGS = $(AM_CFLAGS) | ||
@@ -65,18 +65,18 @@ idevice_id_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
|
||
idevicebackup_SOURCES = idevicebackup.c | ||
idevicebackup_CFLAGS = $(AM_CFLAGS) | ||
-idevicebackup_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicebackup_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicebackup_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicebackup_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicebackup2_SOURCES = idevicebackup2.c | ||
idevicebackup2_CFLAGS = $(AM_CFLAGS) | ||
-idevicebackup2_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicebackup2_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicebackup2_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicebackup2_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
ideviceimagemounter_SOURCES = ideviceimagemounter.c | ||
ideviceimagemounter_CFLAGS = $(AM_CFLAGS) | ||
-ideviceimagemounter_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-ideviceimagemounter_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+ideviceimagemounter_LDFLAGS = $(AM_LDFLAGS) | ||
+ideviceimagemounter_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicescreenshot_SOURCES = idevicescreenshot.c | ||
idevicescreenshot_CFLAGS = $(AM_CFLAGS) | ||
@@ -95,13 +95,13 @@ idevicedate_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
|
||
ideviceprovision_SOURCES = ideviceprovision.c | ||
ideviceprovision_CFLAGS = $(AM_CFLAGS) | ||
-ideviceprovision_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-ideviceprovision_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+ideviceprovision_LDFLAGS = $(AM_LDFLAGS) | ||
+ideviceprovision_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicedebugserverproxy_SOURCES = idevicedebugserverproxy.c | ||
idevicedebugserverproxy_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS) | ||
-idevicedebugserverproxy_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicedebugserverproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicedebugserverproxy_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicedebugserverproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicediagnostics_SOURCES = idevicediagnostics.c | ||
idevicediagnostics_CFLAGS = $(AM_CFLAGS) | ||
@@ -110,8 +110,8 @@ idevicediagnostics_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
|
||
idevicedebug_SOURCES = idevicedebug.c | ||
idevicedebug_CFLAGS = $(AM_CFLAGS) | ||
-idevicedebug_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicedebug_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicenotificationproxy_SOURCES = idevicenotificationproxy.c | ||
idevicenotificationproxy_CFLAGS = $(AM_CFLAGS) | ||
@@ -120,10 +120,10 @@ idevicenotificationproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
|
||
idevicecrashreport_SOURCES = idevicecrashreport.c | ||
idevicecrashreport_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS) | ||
-idevicecrashreport_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicecrashreport_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicecrashreport_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicecrashreport_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
|
||
idevicesetlocation_SOURCES = idevicesetlocation.c | ||
idevicesetlocation_CFLAGS = $(AM_CFLAGS) | ||
-idevicesetlocation_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
-idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
+idevicesetlocation_LDFLAGS = $(AM_LDFLAGS) | ||
+idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters