Skip to content

Commit

Permalink
dev-tcltk/tkimg: version bump to 1.4.12
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jan 21, 2021
1 parent 4249bc8 commit f7b5918
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-tcltk/tkimg/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST Img-1.4.11-Source.tar.gz 7610956 BLAKE2B f461ddb07681c15ca68f8a023808c1c9aec63eefe434c46e09b22f48025b3ec4b095fa44092e30799af3a0435562fd1917613a7ed3f9612d166014cd34834142 SHA512 792223fdb310370937669ef537662947f087131a001281e8923095892b585354690612a339d03f3939b91870016256c37e41aa6305db70e8db1b5ab590610751
DIST Img-1.4.12-Source.tar.gz 8363871 BLAKE2B ba33908be9d44979e6f97c9194dde6ba30fe15593d80fe47cfad22d1d9e81a9e2ca3f2f19adf2c851fb89ad543f28be7e519ed822d3497b073ec93525272e60b SHA512 40602443657c7c0c7196cfad73ca83e3e473c9d08a1f378a6371a61a8eb98dd90ad8cf9aaf4c54fe6388d4abd969b2643029453871dee6dbcf909fa85b039a1a
DIST Img-1.4.9-Source.tar.gz 7702460 BLAKE2B 958956e786cea208f24a30532fa65914439d8289a4fce7dfa149e8202d1abe680bd8cb1cc5d8b3fb3e31d48bf5302db14977997f92ebaa786503138be872fa0b SHA512 c749a567de4eb2b9acc4d84344141ed8ba3703e4e22895d3fe0b292fe10bb0c09920cd765952fa1b95bfe8c0cb5e2955421c29bedaa07b7f3b36e7697a8f36c9
DIST tkimg-1.4.11-patchset-1.tar.gz 9864 BLAKE2B bee2ddd4b0ada51f9aeffc1e4ddcb9ea2d3fec37eccdaf9a1d26551e7e2dd01a466cad91ea33635ce674261d92fc1dc1fa80f3d19dffd92bb5f9bb5425820318 SHA512 013a70826c5a7b083479e6a4cb56421384400dda9ca05b7216b877b9a79d009ee0f80db25c0b0e51b05904b7d74f4d0220cdb92e819404422743c06a1199245f
DIST tkimg-1.4.12-patchset-1.tar.gz 3494 BLAKE2B 3b172f4a5cae4d9ee0668957a5991317e4ae882f450335412488fd408971717facb0c1e1760dc55c20b14e315246017975699d3c1ff9968c3f8182198d85c62a SHA512 a9b9d9b7d0a1faeb7da02a5c7f2ee363e4cb68914ec5c39867ab6ee35b6df988e36d653536b48512361d3a0130c38683f72bb6a76a251820d8689398de3e73ee
DIST tkimg-1.4.7-patchset-1.tar.xz 8208 BLAKE2B c2e6f5d6ef415c897cac33da4a003efec467312e844912e5a519cfb3ddf04ac5cac830eed05418ef74f931df2211c53c40669e53ce3bed219a7c2c714a398de5 SHA512 596c505db7f2ff40c786b83a018eba7f82718d350b6a601f8b93aa64fac238d6b8def603cd719f89fc526e5d2891a94b46de1a2ba628b8ff0ec80979892e28d8
98 changes: 98 additions & 0 deletions dev-tcltk/tkimg/tkimg-1.4.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools eutils multilib prefix toolchain-funcs virtualx

MYP=Img-${PV}-Source

DESCRIPTION="Adds a lot of image formats to Tcl/Tk"
HOMEPAGE="http://tkimg.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}/1.4/${PN}%20${PV}/${MYP}.tar.gz
https://dev.gentoo.org/~tupone/distfiles/${P}-patchset-1.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test static-libs"

RDEPEND="
dev-lang/tk:=
>=dev-tcltk/tcllib-1.11
media-libs/tiff:0=
>=media-libs/libpng-1.6:0=
>=sys-libs/zlib-1.2.7:=
x11-libs/libX11
virtual/jpeg:="
DEPEND="${RDEPEND}
test? (
x11-apps/xhost
media-fonts/font-misc-misc
media-fonts/font-cursor-misc )"

S="${WORKDIR}/Img-${PV}"

PATCHES=(
"${WORKDIR}"/patchset-1
)

src_prepare() {
edos2unix \
libjpeg/jpegtclDecls.h \
libjpeg/Makefile.in \
zlib/Makefile.in \
zlib/zlibtcl.decls \
zlib/zlibtclDecls.h \
libpng/Makefile.in \
libpng/pngtclDecls.h \
libtiff/Makefile.in \
libtiff/tifftclDecls.h \
libtiff/tifftclStubInit.c \
tiff/tiff.c \
jpeg/jpeg.c
default
find compat/libtiff/config -name ltmain.sh -delete

#rm -r compat/{libjpeg,libpng,zlib} || die

eautoreconf
for dir in zlib libpng libtiff libjpeg base bmp gif ico jpeg pcx pixmap png\
ppm ps sgi sun tga tiff window xbm xpm dted raw flir ; do
(cd $dir; AT_NOELIBTOOLIZE=yes eautoreconf)
done

eprefixify */*.h
tc-export AR
}

src_test() {
virtx default
}

src_install() {
local l bl

emake \
DESTDIR="${D}" \
INSTALL_ROOT="${D}" \
install

if ! use static-libs; then
find "${ED}"/usr/$(get_libdir)/ -type f -name "*\.a" -delete || die
fi

# Make library links
for l in "${ED}"/usr/lib*/Img*/*tcl*.so; do
bl=$(basename $l)
dosym Img${PV}/${bl} /usr/$(get_libdir)/${bl}
done

dodoc ChangeLog README Reorganization.Notes.txt changes ANNOUNCE

if use doc; then
docompress -x usr/share/doc/${PF}/demo.tcl
dodoc demo.tcl
docinto html
dodoc -r doc/*
fi
}

0 comments on commit f7b5918

Please sign in to comment.