Skip to content

Commit

Permalink
media-sound/splay: Allow for compiling with GCC 6
Browse files Browse the repository at this point in the history
Gentoo-bug: 594684

Package-Manager: portage-2.3.1
  • Loading branch information
SoapGentoo committed Oct 2, 2016
1 parent 3e2387f commit f82fb92
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 0 deletions.
28 changes: 28 additions & 0 deletions media-sound/splay/files/splay-0.9.5.2-fix-c++14.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
Fix building with C++14, which errors out due to narrowing conversions.
See also: https://bugs.gentoo.org/show_bug.cgi?id=594684

--- a/libs/huffmantable.cc
+++ b/libs/huffmantable.cc
@@ -550,11 +550,11 @@

const HUFFMANCODETABLE Mpegtoraw::ht[HTN]=
{
- { 0, 0-1, 0-1, 0, 0, htd33},
+ { 0, (unsigned int)(0-1), (unsigned int)(0-1), 0, 0, htd33},
{ 1, 2-1, 2-1, 0, 7,htd01},
{ 2, 3-1, 3-1, 0, 17,htd02},
{ 3, 3-1, 3-1, 0, 17,htd03},
- { 4, 0-1, 0-1, 0, 0, htd33},
+ { 4, (unsigned int)(0-1), (unsigned int)(0-1), 0, 0, htd33},
{ 5, 4-1, 4-1, 0, 31,htd05},
{ 6, 4-1, 4-1, 0, 31,htd06},
{ 7, 6-1, 6-1, 0, 71,htd07},
@@ -564,7 +564,7 @@
{11, 8-1, 8-1, 0,127,htd11},
{12, 8-1, 8-1, 0,127,htd12},
{13,16-1,16-1, 0,511,htd13},
- {14, 0-1, 0-1, 0, 0, htd33},
+ {14, (unsigned int)(0-1), (unsigned int)(0-1), 0, 0, htd33},
{15,16-1,16-1, 0,511,htd15},
{16,16-1,16-1, 1,511,htd16},
{17,16-1,16-1, 2,511,htd16},
1 change: 1 addition & 0 deletions media-sound/splay/splay-0.9.5.2-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}/${P}-external-id3lib.diff"
"${FILESDIR}/${P}-gcc43-2.patch"
"${FILESDIR}/${P}-fix-buildsystem.patch"
"${FILESDIR}/${P}-fix-c++14.patch"
)

src_prepare() {
Expand Down

0 comments on commit f82fb92

Please sign in to comment.