Skip to content

Commit

Permalink
app-editors/kakoune: fix a linking bug
Browse files Browse the repository at this point in the history
Fix a ncurses[tinfo] linking bug
(see upstream mawww/kakoune#695):
moved configuration of ncurses linker libs to ebuild, until
upstream supports pkg-config

bind to current ncurses slot
  • Loading branch information
Hummer12007 authored and gktrk committed Jun 22, 2016
1 parent 008c8a1 commit f875a67
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 22 deletions.
6 changes: 4 additions & 2 deletions app-editors/kakoune/files/kakoune-makefile.patch
Original file line number Diff line number Diff line change
Expand Up @@ -24,9 +24,11 @@ index c79c270..9409a8c 100644
sharedir := $(DESTDIR)$(PREFIX)/share/kak
docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
@@ -53,11 +51,10 @@ else ifneq (,$(findstring CYGWIN,$(os)))
LIBS += -lncursesw -lboost_regex -ldbghelp
- LIBS += -lncursesw -lboost_regex -ldbghelp
+ LIBS += -lboost_regex -ldbghelp
else
LIBS += -lncursesw -lboost_regex
- LIBS += -lncursesw -lboost_regex
+ LIBS += -lboost_regex
- CPPFLAGS += -I$(NCURSESW_INCLUDE)
LDFLAGS += -rdynamic
endif
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug"

RDEPEND="
sys-libs/ncurses:*[unicode]
sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
Expand All @@ -31,18 +31,12 @@ PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )

src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
}

src_compile() {
emake -C src
}

src_test() {
emake -C src test
S="${WORKDIR}/${P}/src"
}

src_install() {
emake -C src DESTDIR="${D}" PREFIX="/usr" install
emake DESTDIR="${D}" PREFIX="/usr" install
}
14 changes: 4 additions & 10 deletions app-editors/kakoune/kakoune-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ KEYWORDS=""
IUSE="debug"

RDEPEND="
sys-libs/ncurses:*[unicode]
sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
Expand All @@ -29,18 +29,12 @@ PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )

src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
}

src_compile() {
emake -C src
}

src_test() {
emake -C src test
S="${WORKDIR}/${P}/src"
}

src_install() {
emake -C src DESTDIR="${D}" PREFIX="/usr" install
emake DESTDIR="${D}" PREFIX="/usr" install
}

0 comments on commit f875a67

Please sign in to comment.