Skip to content

Commit

Permalink
dev-libs/re2: Version bump (0.2020.06.01).
Browse files Browse the repository at this point in the history
Static library no longer installed.

Closes: https://bugs.gentoo.org/723166
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <[email protected]>
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed Jun 13, 2020
1 parent 60b7072 commit f937eb1
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/re2/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST re2-2019-12-01.tar.gz 391450 BLAKE2B 2069b496d494771d09d2ce289cc3cd45ea99fda17ca044f09ebeddae85c6fb2cabcb34403a8364d179591f7f3d8ad4e39191c1034aa70c8a16f5d439357330ba SHA512 cfbce00a8462644177c2792cdcd1115fdd17dae9454f6148764bf22c4f364002c6d561f4f407564f6925b78fa8a252d6a3b02bfa8a63f347e6b3d33034ec2d77
DIST re2-2020-04-01.tar.gz 402511 BLAKE2B ce3f17037a3a09867036e651d62bd9f004b7ed7c6813b4530059659e794a7a7a3ad17d6ee35b5456302d627a0524fc78151b60ed9c546c1baab699231554a0dd SHA512 b3f2ec675fbc2ab18fc4de7b8c077f110010fd4a7502eea3d802d3706681b523db551edd80c2ff188457169471899084a6b21937154ab2288ee9ac123a2b7014
DIST re2-2020-05-01.tar.gz 402569 BLAKE2B da94442ad8fa965ce8e38f19184579a033a65fd2cdd7769e2e2f2fdb590cd79adf275e94a8aa4ca6924c4b7879441ba7632cc492daa67d41cebeead67af6fc65 SHA512 76ab9b63a7de3de1dbde599e9fd35cf94de26f2f3c2a85e3befa0026decc95620fac65c7bcbfa3729efbfe6b1b418d77d733bd27496b54c649ac2918652aaaac
DIST re2-2020-06-01.tar.gz 403203 BLAKE2B 46270c39fdb9eda127752e97e5dfea24a6cb9ddc32bfc298e123eb29609a003fd1a7a3591e760944ec36721ee1981f9bdbbc0b04d596764922e6bbc3daa9159c SHA512 8592a5409cb087c3188023746a4121bd58972a7a21bae98022af587f6191b3096bbb5d379e622ea853ff3373c76972fb61f331354550715c9a7e77d08fba6f3c
52 changes: 52 additions & 0 deletions dev-libs/re2/re2-0.2020.06.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multilib-minimal toolchain-funcs

# Different date format used upstream.
RE2_VER=${PV#0.}
RE2_VER=${RE2_VER//./-}

DESCRIPTION="An efficient, principled regular expression library"
HOMEPAGE="https://github.com/google/re2"
SRC_URI="https://github.com/google/re2/archive/${RE2_VER}.tar.gz -> re2-${RE2_VER}.tar.gz"

LICENSE="BSD"
# NOTE: Always run libre2 through abi-compliance-checker!
# https://abi-laboratory.pro/tracker/timeline/re2/
SONAME="7"
SLOT="0/${SONAME}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="icu"

BDEPEND="icu? ( virtual/pkgconfig )"
DEPEND="icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"

S="${WORKDIR}/re2-${RE2_VER}"

DOCS=( AUTHORS CONTRIBUTORS README doc/syntax.txt )
HTML_DOCS=( doc/syntax.html )

src_prepare() {
default
grep -q "^SONAME=${SONAME}\$" Makefile || die "SONAME mismatch"
if use icu; then
sed -i -e 's:^# \(\(CC\|LD\)ICU=.*\):\1:' Makefile || die
fi
multilib_copy_sources
}

src_configure() {
tc-export AR CXX
}

multilib_src_compile() {
emake SONAME="${SONAME}" shared
}

multilib_src_install() {
emake SONAME="${SONAME}" DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="\$(exec_prefix)/$(get_libdir)" shared-install
}

0 comments on commit f937eb1

Please sign in to comment.