Skip to content

Commit

Permalink
games-arcade/supertux: Bump to version 0.5.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Lars Wendler committed Nov 9, 2016
1 parent a5a59d3 commit fb70b75
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/supertux/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST SuperTux-v0.5.0-Source.tar.gz 90564579 SHA256 cfae0da40c41532fb414c3b17891c98396b59471fe583a8fc756b96aea61a73b SHA512 dcd4d361eee34d8ab25e680cec328b0931a001f8ab97d0b40b03291e9214fdb64cc08fbccb81f524e5f6ba9921414bdf58dc29e27ff663a0160f678b6908b783 WHIRLPOOL ffee5ad36bc305e9df5f9e4a31d3ea5bfb6684ee8c91ced44ed072e5262dd2c8e4fff676fd5abc2bdfa6ab942ec5d18b6864ebe0882eb3d0f78213e14fa51eb3
DIST SuperTux-v0.5.1-Source.tar.gz 90564367 SHA256 c9dc3b42991ce5c5d0d0cb94e44c4ec2373ad09029940f0e92331e7e9ada0ac5 SHA512 1a841cec9b71ff482aa271ec94f0563052ed33c65b26958c15c818f897f184356605a115abb70bdb8302f8cdb6e6107cf336790c3929cbc7e3dc78d31b4e2c8a WHIRLPOOL 2be132c1265d119acb24dd900c49f40c2b12cac51646bfb9c970e0b97d030210ce885ac8932815c15a1d67e28cbba8e6a0301eee4becf78cf995668641f18830
DIST supertux-0.4.0.tar.bz2 79713147 SHA256 d18dde3c415e619b4bb035e694ffc384be16576250c9df16929d9ec38daff782 SHA512 66ca63c982b6076847662c187069eb965211439e5dfc628300f2a9bd0d2b4c0f7b53f6e7c2aed263c098cc9b77fedf132e73b1f3b3eacaf5535cae8300262fb5 WHIRLPOOL 12551b655f0459a37d3b91b1eff058ec383df34c9f3c29c1e8a63c070c12b32ec798b772053cd08b11d32b612bab1188b69678e71585279e94ad380052076f64
67 changes: 67 additions & 0 deletions games-arcade/supertux/supertux-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit cmake-utils flag-o-matic

MY_P="SuperTux-v${PV}-Source"

DESCRIPTION="A game similar to Super Mario Bros."
HOMEPAGE="http://supertuxproject.org/"
SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"

LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"

RDEPEND="dev-games/physfs
dev-libs/boost:=
media-libs/glew:=
virtual/opengl
media-libs/libvorbis
media-libs/openal
>=media-libs/libsdl2-2.0.1[joystick,video]
>=media-libs/sdl2-image-2.0.0[png,jpeg]
>=net-misc/curl-7.21.7"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-0.4.0-{desktop,license,icon}.patch
"${FILESDIR}"/${PN}-0.5.0-{obstack,tinygettext}.patch
)

src_prepare() {
default

# This is not a developer release so switch the logo to the non-dev one.
sed 's@logo_dev@logo@' \
-i data/images/objects/logo/logo.sprite || die
}

src_configure() {
append-cxxflags -std=c++11
local mycmakeargs=(
-DWERROR=OFF
-DINSTALL_SUBDIR_BIN=bin
-DINSTALL_SUBDIR_DOC=share/doc/${PF}
-DINSTALL_SUBDIR_SHARE=share/${PN}2
-DENABLE_SQDBG="$(usex debug)"
-DUSE_DEBUG="$(usex debug)"
-DENABLE_BOOST_STATIC_LIBS=OFF # bug! Please check if this is still required.
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
}

0 comments on commit fb70b75

Please sign in to comment.