Skip to content

Commit

Permalink
app-crypt/tpm2-tss: Bump to 3.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Salah Coronya <[email protected]>
Closes: gentoo#17025
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
salahcoronya authored and juippis committed Sep 6, 2020
1 parent 47af162 commit fb7e62b
Show file tree
Hide file tree
Showing 4 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/tpm2-tss/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tpm2-tss-2.4.1.tar.gz 1445103 BLAKE2B c7be91b93d19b5afeddb6ec455db9ba06795f8dc76ee2a0c6cbabbd8f623930d7c9fdf6319497c70790445531d1e36fe3f904f4c1f4bc9254d833b6d19280f1f SHA512 51551d63fa404e23664aaad1b247bd4b1f93812ced1aed144c37f28cdb3adb4e696aa9e93a502c8fa0eb7e9b4376ac9377f0537eb4c717b68c0b014fee7a0643
DIST tpm2-tss-2.4.2.tar.gz 1461987 BLAKE2B 7d37818ba91c4128862206d5179dcde2c5149b5b00807b242a0b4311531ad2da9e8ad435a6b46872aab5eb91777012010a352ba0f478737740175e0353275643 SHA512 db31d216abcefdad76f5d9ff2995c99c552400392a4dec800b962fa1fa3ac83effacca831602a9b7f814045c996a1bb066802c5373b54233aa24ddafd636c27e
DIST tpm2-tss-3.0.0.tar.gz 1509288 BLAKE2B 23c46ba6c9ea2b61703556d3aab5b4e75b1a0242a688c44e8c254a4defd8258e100a933598755373ffec9db3ca0ab9d35e6a290a73851c2a456449e04bd8313a SHA512 ba54904f2cd8cbcca85ce4d4ac5c8650da6ab076e8d8d142e1b7ee75c5e9a645520f1a5ac8ffe5269deceba84762c9074b131296e8b2d4c684ddc335a828d7a8
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
diff --git a/Makefile.am b/Makefile.am
index f2fa515a..7d2aca29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -664,11 +664,6 @@ endif #FAPI
EXTRA_DIST += dist/tpm-udev.rules

install-dirs:
-if HOSTOS_LINUX
- (systemd-sysusers && systemd-tmpfiles --create) || \
- ($(call make_tss_user_and_group) && $(call make_fapi_dirs) && ($call set_fapi_permissions)) || true
- $(call check_fapi_dirs)
-endif

install-data-hook: install-dirs
-if [ ! -z "$(udevrulesprefix)" ]; then \
1 change: 1 addition & 0 deletions app-crypt/tpm2-tss/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,7 @@
<use>
<flag name="fapi">Enable feature API (requires openssl as crypto backend)</flag>
<flag name="gcrypt">Use <pkg>dev-libs/libgcrypt</pkg> as crypto engine</flag>
<flag name="mbedtls">Use <pkg>net-libs/mbedtls</pkg> as crypto engine</flag>
<flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as crypto engine</flag>
</use>
<upstream>
Expand Down
75 changes: 75 additions & 0 deletions app-crypt/tpm2-tss/tpm2-tss-3.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools linux-info tmpfiles udev

DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc +fapi +openssl mbedtls static-libs test"

RESTRICT="!test? ( test )"

REQUIRED_USE="^^ ( mbedtls openssl )
fapi? ( openssl !mbedtls )"

RDEPEND="acct-group/tss
acct-user/tss
fapi? ( dev-libs/json-c
net-misc/curl )
mbedtls? ( net-libs/mbedtls:= )
openssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}
test? ( dev-util/cmocka )"
BDEPEND="virtual/pkgconfig
doc? ( app-doc/doxygen )"

PATCHES=(
"${FILESDIR}/${P}-Dont-run-systemd-sysusers-in-Makefile.patch"
)

pkg_setup() {
local CONFIG_CHECK=" \
~TCG_TPM
"
linux-info_pkg_setup
kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
}

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
--localstatedir=/var \
$(use_enable doc doxygen-doc) \
$(use_enable fapi) \
$(use_enable static-libs static) \
$(use_enable test unit) \
--disable-tcti-mssim \
--disable-defaultflags \
--disable-weakcrypto \
--with-crypto="$(usex mbedtls mbed ossl)" \
--with-runstatedir=/run \
--with-udevrulesdir="$(get_udevdir)/rules.d" \
--with-udevrulesprefix=60- \
--with-sysusersdir="/usr/lib/sysusers.d" \
--with-tmpfilesdir="/usr/lib/tmpfiles.d"
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
tmpfiles_process tpm2-tss-fapi.conf
}

0 comments on commit fb7e62b

Please sign in to comment.