Skip to content

Commit

Permalink
dev-db/percona-xtrabackup: version bump to 2.4.7.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4458
  • Loading branch information
hydrapolic authored and monsieurp committed Apr 26, 2017
1 parent 74d23e4 commit fc0e93f
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/percona-xtrabackup/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST percona-xtrabackup-2.4.6.tar.gz 54108124 SHA256 1e21ab097550901d8f2fa3dc37402ba6a994afa0722760f8f19cb369565e5e8b SHA512 7ed16ba73d4232cc5f40f3dd4674087b65326b42f3f0d9cd462a1eef1dd2c41c582cb71fff49998d9e65f71322e2b26d0708b2ba36da22f54f456679b9a544e5 WHIRLPOOL 3d53e7a2b7b61c0dd779d723a3efb4d1ab4d98aff751a325e6028c0710a1f4de969d70f62c65a8a0e67f0d95643a0245524fb37708602ef303f21674c5f92fe3
DIST percona-xtrabackup-2.4.7.tar.gz 54119422 SHA256 261567a4f0bdde0df7eefeb4f651ad39b4752984bbaabd68245e0e5ee368871a SHA512 7aaf82975cd4c0b7af119902eddf96b8ce75c0fbcbd6835991e33f1f89347361fbe3c9040762c9989df5d53199b628aa6b2b45004ef440bb46e2415fbab13009 WHIRLPOOL 768749471ac987a24f86d07b330988cb679042be5a8affd264f1195eeeacaa8e403370d558316708a056acb4b0ad78083e195f31a4f2a58bc497bf301be2ddb1
74 changes: 74 additions & 0 deletions dev-db/percona-xtrabackup/percona-xtrabackup-2.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils flag-o-matic

DESCRIPTION="Hot backup utility for MySQL based servers"
HOMEPAGE="https://www.percona.com/software/mysql-database/percona-xtrabackup"
SRC_URI="https://www.percona.com/downloads/XtraBackup/Percona-XtraBackup-${PV}/source/tarball/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
app-arch/lz4:0=
app-editors/vim-core
>=dev-libs/boost-1.59.0:=
dev-libs/libaio
dev-libs/libedit
dev-libs/libevent:0=
dev-libs/libgcrypt:0=
dev-libs/libgpg-error
dev-python/sphinx
net-misc/curl
sys-libs/zlib"
RDEPEND="${DEPEND}
!dev-db/xtrabackup-bin
dev-perl/DBD-mysql"

PATCHES=(
"${FILESDIR}"/${PN}-2.4.6-remove-boost-version-check.patch
"${FILESDIR}"/${PN}-2.4.6-fix-gcc6-isystem.patch
)

src_prepare() {
cmake-utils_src_prepare

# remove bundled lz4, boost, libedit, libevent, zlib
# just to be safe...
rm -r extra/lz4 include/boost_1_59_0 \
cmd-line-utils/libedit libevent zlib || die
}

src_configure() {
# Needed, due to broken handling of CMAKE_BUILD_TYPE leading to
#
# error: 'fts_ast_node_type_get' was not declared in this scope
#
append-cppflags -DDBUG_OFF

local mycmakeargs=(
-DBUILD_CONFIG=xtrabackup_release
-DWITH_EDITLINE=system
-DWITH_LIBEVENT=system
-DWITH_LZ4=system
-DWITH_SSL=bundled # uses yassl, which isn't packaged
-DWITH_ZLIB=system
-DWITH_PIC=ON
)
cmake-utils_src_configure
}

src_install() {
local p="${BUILD_DIR}/storage/innobase/xtrabackup"

dobin "${p}"/src/{xbcloud,xbcrypt,xbstream,xtrabackup}
dosym xtrabackup /usr/bin/innobackupex

einstalldocs
doman "${p}"/doc/source/build/man/*
}

0 comments on commit fc0e93f

Please sign in to comment.