Skip to content

Commit

Permalink
dev-python/pytest-ordering: move from ::guru
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.2, Repoman-2.3.23
Signed-off-by: Andrew Ammerlaan <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
Nowa-Ammerlaan authored and juippis committed Sep 15, 2020
1 parent a98473a commit fc9c054
Show file tree
Hide file tree
Showing 3 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pytest-ordering/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pytest-ordering-0.6.tar.gz 11046 BLAKE2B 468ae5f04029b96ed3058b7f429aec0aaf96092453b229c3de5eab174702af2c1a9fe83171c68d282c4a144b3dd736daf9ed87b9e139a7bd175114f504049ebc SHA512 fd3aec83914f64d1295e1a1bf3fdc580c6824a749a1da8cebae275fef940d6ed6e5dcafad321d94f504a153e13e298b6544dc3c2db716a6b25d3148c2365fe15
17 changes: 17 additions & 0 deletions dev-python/pytest-ordering/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">

<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Andrew Ammerlaan</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
<remote-id type="github">https://github.com/ftobia/pytest-ordering</remote-id>
<remote-id type="pypi">pytest-ordering</remote-id>
</upstream>
</pkgmetadata>
34 changes: 34 additions & 0 deletions dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )

DISTUTILS_USE_SETUPTOOLS=rdepend

inherit distutils-r1

DESCRIPTION="pytest plugin to run your tests in a specific order"
HOMEPAGE="
https://github.com/ftobia/pytest-ordering
https://pypi.org/project/pytest-ordering
"
SRC_URI="https://github.com/ftobia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="test? ( dev-python/pytest-ordering[${PYTHON_USEDEP}] )"

distutils_enable_tests pytest
distutils_enable_sphinx docs/source

python_prepare_all() {
# TypeError: `args` parameter expected to be a list or tuple of strings, got: '--markers' (type: <class 'str'>)
sed -i -e 's:test_run_marker_registered:_&:' \
tests/test_ordering.py || die

distutils-r1_python_prepare_all
}

0 comments on commit fc9c054

Please sign in to comment.