Skip to content

Commit

Permalink
games-puzzle/brainparty: tweak for gcc-11
Browse files Browse the repository at this point in the history
Reported-by: Kobboi
Closes: https://bugs.gentoo.org/768204
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Feb 11, 2021
1 parent 0fb35bb commit fdb3061
Show file tree
Hide file tree
Showing 2 changed files with 15 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-puzzle/brainparty/brainparty-0.61-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,6 +28,7 @@ PATCHES=(
"${FILESDIR}"/${P}-savegame.patch
"${FILESDIR}"/${P}-gcc49.patch
"${FILESDIR}"/${P}-gnu_cxx-hash.patch
"${FILESDIR}"/${P}-gcc-11.patch
)

src_prepare() {
Expand Down
14 changes: 14 additions & 0 deletions games-puzzle/brainparty/files/brainparty-0.61-gcc-11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
gcc-11 needs const operator()

https://bugs.gentoo.org/768204
--- a/BPGame.h
+++ b/BPGame.h
@@ -53,7 +53,7 @@ class BPMiniGame;
class SpriteFont;

struct cmp_str {
- bool operator()(char const *a, char const *b) {
+ bool operator()(char const *a, char const *b) const {
return std::strcmp(a, b) < 0;
}
};

0 comments on commit fdb3061

Please sign in to comment.