Skip to content

Commit

Permalink
games-arcade/supertux: Bump to version 0.5.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Sep 27, 2016
1 parent 4ed163d commit fde5a5b
Show file tree
Hide file tree
Showing 8 changed files with 125 additions and 8 deletions.
1 change: 1 addition & 0 deletions games-arcade/supertux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST SuperTux-v0.5.0-Source.tar.gz 90564579 SHA256 cfae0da40c41532fb414c3b17891c98396b59471fe583a8fc756b96aea61a73b SHA512 dcd4d361eee34d8ab25e680cec328b0931a001f8ab97d0b40b03291e9214fdb64cc08fbccb81f524e5f6ba9921414bdf58dc29e27ff663a0160f678b6908b783 WHIRLPOOL ffee5ad36bc305e9df5f9e4a31d3ea5bfb6684ee8c91ced44ed072e5262dd2c8e4fff676fd5abc2bdfa6ab942ec5d18b6864ebe0882eb3d0f78213e14fa51eb3
DIST supertux-0.4.0.tar.bz2 79713147 SHA256 d18dde3c415e619b4bb035e694ffc384be16576250c9df16929d9ec38daff782 SHA512 66ca63c982b6076847662c187069eb965211439e5dfc628300f2a9bd0d2b4c0f7b53f6e7c2aed263c098cc9b77fedf132e73b1f3b3eacaf5535cae8300262fb5 WHIRLPOOL 12551b655f0459a37d3b91b1eff058ec383df34c9f3c29c1e8a63c070c12b32ec798b772053cd08b11d32b612bab1188b69678e71585279e94ad380052076f64
4 changes: 2 additions & 2 deletions games-arcade/supertux/files/supertux-0.4.0-desktop.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- supertux2.desktop.orig
+++ supertux2.desktop
--- a/supertux2.desktop
+++ b/supertux2.desktop
@@ -35,7 +35,7 @@
Comment[pt]=Joga este clássico de plataformas 2D
Comment[pt_BR]=Encarne o pinguin Tux neste jogo inspirado em clássicos de Pular&Correr
Expand Down
4 changes: 2 additions & 2 deletions games-arcade/supertux/files/supertux-0.4.0-flags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -329,7 +329,7 @@
endif(COMPILER_SUPPORTS_CXX11)

Expand Down
4 changes: 2 additions & 2 deletions games-arcade/supertux/files/supertux-0.4.0-icon.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -571,7 +571,7 @@

SET(APPS "\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${INSTALL_SUBDIR_BIN}/supertux2")
Expand Down
4 changes: 2 additions & 2 deletions games-arcade/supertux/files/supertux-0.4.0-license.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -578,7 +578,7 @@

INSTALL(TARGETS supertux2_exe DESTINATION ${INSTALL_SUBDIR_BIN})
Expand Down
19 changes: 19 additions & 0 deletions games-arcade/supertux/files/supertux-0.5.0-obstack.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
--- supertux-0.5.0/CMakeLists.txt
+++ supertux-0.5.0/CMakeLists.txt
@@ -382,7 +382,6 @@
include_directories(${CMAKE_BINARY_DIR}/)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src/)
include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/external/findlocale/)
-include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/external/obstack/)
include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/external/sexp-cpp/include/)

IF(WIN32)
@@ -392,7 +391,7 @@

## Build list of sources for supertux binary

-FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/obstack/*.c external/findlocale/findlocale.c)
+FILE(GLOB SUPERTUX_SOURCES_C RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} external/findlocale/findlocale.c)

FILE(GLOB SUPERTUX_SOURCES_CXX RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} src/*/*.cpp src/supertux/menu/*.cpp src/video/sdl/*.cpp)
FILE(GLOB SUPERTUX_RESOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${PROJECT_BINARY_DIR}/tmp/*.rc")
30 changes: 30 additions & 0 deletions games-arcade/supertux/files/supertux-0.5.0-tinygettext.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
--- SuperTux-v0.5.0-Source/external/tinygettext/CMakeLists.txt
+++ SuperTux-v0.5.0-Source/external/tinygettext/CMakeLists.txt
@@ -59,7 +59,7 @@
)

## Reveal library type choice to users
-option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" ON)
+option(BUILD_SHARED_LIBS "Produce dynamic library instead of static archive" OFF)

# TinyGetText library compilation

@@ -128,17 +128,7 @@
## Debug options

option(WERROR "Stops on first compiler warning in debug mode" OFF)
-option(WARNINGS "Enable long list of warnings for compiler to check" ON)
-
-CHECK_CXX_FLAG(std=c++0x)
-CHECK_CXX_FLAG(O3)
-IF(NOT MSVC)
- #MSVC is excessivly verbose when Wall is activated
- CHECK_CXX_FLAG(Wall)
-ENDIF()
-CHECK_CXX_FLAG(Wextra)
-CHECK_CXX_FLAG(Weffc++)
-CHECK_CXX_FLAG(pedantic)
+option(WARNINGS "Enable long list of warnings for compiler to check" OFF)

if(WARNINGS)
CHECK_CXX_FLAG(Wabi)
67 changes: 67 additions & 0 deletions games-arcade/supertux/supertux-0.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit cmake-utils flag-o-matic

MY_P="SuperTux-v${PV}-Source"

DESCRIPTION="A game similar to Super Mario Bros."
HOMEPAGE="http://supertuxproject.org/"
SRC_URI="https://github.com/SuperTux/supertux/releases/download/v${PV}/${MY_P}.tar.gz"

LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"

RDEPEND="dev-games/physfs
dev-libs/boost:=
media-libs/glew:=
virtual/opengl
media-libs/libvorbis
media-libs/openal
>=media-libs/libsdl2-2.0.1[joystick,video]
>=media-libs/sdl2-image-2.0.0[png,jpeg]
>=net-misc/curl-7.21.7"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-0.4.0-{desktop,license,icon}.patch
"${FILESDIR}"/${P}-{obstack,tinygettext}.patch
)

src_prepare() {
default

# This is not a developer release so switch the logo to the non-dev one.
sed 's@logo_dev@logo@' \
-i data/images/objects/logo/logo.sprite || die
}

src_configure() {
append-cxxflags -std=c++11
local mycmakeargs=(
-DWERROR=OFF
-DINSTALL_SUBDIR_BIN=bin
-DINSTALL_SUBDIR_DOC=share/doc/${PF}
-DINSTALL_SUBDIR_SHARE=share/${PN}2
-DENABLE_SQDBG="$(usex debug)"
-DUSE_DEBUG="$(usex debug)"
-DENABLE_BOOST_STATIC_LIBS=OFF # bug! Should be fixed in next release
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
}

0 comments on commit fde5a5b

Please sign in to comment.