Skip to content

Commit

Permalink
dev-libs/liblouis: Version bump to 3.17.0
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Apr 19, 2021
1 parent 81e8e7d commit fe179d6
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/liblouis/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST liblouis-3.13.0.tar.gz 14683684 BLAKE2B 9596fac30ee8512498826ea11c3fe4d9dfba6706166938852242533f1fadde9ca8e363ea1364ebb4266b366ee49863d84ad757f8634d90e48dd8c562c31e9e8d SHA512 68f0205dc55a106c5707f959c1c0d3c121dfe62f263a664e6bec0780bee65cce2fb5d7033ae1c8312d1d79f7ccaf650af71906e8651b60f11219758e41051b61
DIST liblouis-3.17.0.tar.gz 14868166 BLAKE2B 2edc5ef4366e29080d0d138fe45d946730e04dea278a14751106a25862f6266fe0fda492e12f4d2aa7d26d7277a11dfa2eaf8be39cdeffbcf83f2c143922e6d6 SHA512 9511e0f76ef6def3fa30f0bce4df188b2a11251e8ced0a76a92e172026e6751bc19b2c8ccd5789043b65398190a367bca03b3f1449344750e63ebd0fde60b4e3
75 changes: 75 additions & 0 deletions dev-libs/liblouis/liblouis-3.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_OPTIONAL=1
inherit distutils-r1

DESCRIPTION="An open-source braille translator and back-translator"
HOMEPAGE="https://github.com/liblouis/liblouis"
SRC_URI="https://github.com/liblouis/liblouis/releases/download/v${PV}/${P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0/20"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"

RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
BDEPEND="sys-apps/help2man
python? ( ${PYTHON_DEPS}
>=dev-python/setuptools-42.0.2[${PYTHON_USEDEP}]
)
test? ( dev-libs/libyaml )
"

src_prepare() {
default

if use python; then
pushd python > /dev/null
distutils-r1_src_prepare
popd > /dev/null
fi
}

src_configure() {
econf \
--enable-ucs4 \
--disable-static
}

src_compile() {
default

if use python; then
pushd python > /dev/null
# setup.py imports liblouis to get the version number,
# and this causes the shared library to be dlopened
# at build-time. Hack around it with LD_PRELOAD.
# Thanks ArchLinux.
LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
distutils-r1_src_compile
popd > /dev/null
fi
}

src_install() {
if use python; then
pushd python > /dev/null
LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
distutils-r1_src_install
popd > /dev/null
fi

# These need to be after distutils src_install, or it'll try to install them from under python/ as well
DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
HTML_DOCS=( doc/liblouis.html )
default

find "${ED}" -name '*.la' -delete || die
}

0 comments on commit fe179d6

Please sign in to comment.