Skip to content

Commit

Permalink
dev-php/pecl-oauth: bump to v2.0.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Sep 30, 2020
1 parent a878d73 commit ff00d82
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-oauth/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST oauth-2.0.5.tgz 49641 BLAKE2B eec258d8dc900c19bea19b0b1db3e1f5b103b65e1298cef0819741181811d98ab86812ab557a3457520bcb6ece48b2b0f081d23897ce06e12b715998cbc1ad2a SHA512 847f8a07aba930d606038a78915ddd9c24aab241d27b844a766e0da3caabf419fd891573524a55b40559a827b1adc1261748efabac5ed1bee45fa770935379ee
DIST oauth-2.0.7.tgz 78926 BLAKE2B 2fbe8f9c6df19790b9f617af64a04ed2387e904c3775753ac23fcf3f796007891a546ad6d5fae9b04cab707905f5ff3e9cc56b5c0b4bd1d9bab8745428c683f8 SHA512 261bbe6d1c4299f44ce40030b3959e26f2535c70d01b7a4e870d14c84b0a01e68484e61907554d720667fa08a2ec00b7d43cf2f523800c832f02b093e7b6534a
35 changes: 35 additions & 0 deletions dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
PHP_EXT_NAME="oauth"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"

USE_PHP="php7-2 php7-3 php7-4"

inherit php-ext-pecl-r3

KEYWORDS="~amd64 ~x86"

DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
LICENSE="BSD"
SLOT="7"
IUSE="+curl examples"

DEPEND="php_targets_php7-2? ( dev-lang/php:7.2[hash(-)]
dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
php_targets_php7-3? ( dev-lang/php:7.3[hash(-)]
dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
php_targets_php7-4? (
dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
"
RDEPEND="${DEPEND}"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-oauth
$(use_with curl)
)
php-ext-source-r3_src_configure
}

0 comments on commit ff00d82

Please sign in to comment.