Skip to content

Commit

Permalink
dev-vcs/mercurial: Bump to version 4.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
Lars Wendler committed Jun 7, 2018
1 parent da857b2 commit ffd3522
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/mercurial/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mercurial-4.5.2.tar.gz 5779915 BLAKE2B 9abc5a8bafc43bc8e930bb51aa2e57397cd5858dc7bb31d9a37795a4e2799dc03b57130b23e29f89a07bd7502f136594a03d1a4bd5dfd04e2e968213b50413da SHA512 f70e40cba72b7955f0ecec9c1f53ffffac26f206188617cb182e22ce4f43dc8b970ce46d12c516ef88480c3fa076a59afcddd736dffb642d8e23befaf45b4941
DIST mercurial-4.5.3.tar.gz 5884837 BLAKE2B 61e61624cb397786b7a4f6ed62a3ba0c2ed7cbacc5918341d014a7e0fd9bbe07c91def00539411e71d231d18060de8461bef05590626bf1318691f791e0ad2b5 SHA512 9c23ffefb0a194b5a88ee783186347c21e7d973524ba40119439702953b35b01ad6fbc32ce09ae169f1020963e92312a39321b1da3ffe06db1d44158761abbec
DIST mercurial-4.6.1.tar.gz 6407380 BLAKE2B 02663a11c56bbd05f123a0903463d7e95cdf3f2e553b0f81b365b4ca296c15bccd735487162870a4e38253c6c0cb1d8f0cf1bbb1b05b3c3b721f2209e4e1b2ec SHA512 0c7737ca803691b135b4906cc527b20595e314009096d8a19f37814ee192b182e7c5360fbf993f632d6071da1f9fca38677e7190c14ed92bafa8add72a4a27d9
DIST mercurial-4.6.tar.gz 6226745 BLAKE2B 9304fff7f6cc67523e9d1c36aee110f2cfbcf2f059f45072e9175b6cb057273ff13e5823bc7831ac04de2e40b54fa660051861d42426c85b0a62b2c759aaff60 SHA512 2a7e94a338727afc97aab9c33ce4810a17088f5f477a83b581dcbf594e455062e69e6a3782f1665b24ffc011963b0eead6f7e637a63f241d256378d30b006c45
134 changes: 134 additions & 0 deletions dev-vcs/mercurial/mercurial-4.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic

DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"

RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}] )"

SITEFILE="70${PN}-gentoo.el"

PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )

python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die

distutils-r1_python_prepare_all
}

python_configure_all() {
strip-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing

"${PYTHON}" setup.py build_mo || die
}

python_compile_all() {
rm -r contrib/{win32,macosx} || die
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}

python_install_all() {
distutils-r1_python_install_all

newbashcomp contrib/bash_completion hg

insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg

rm -f doc/*.?.txt
dodoc CONTRIBUTORS
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die

dobin hgeditor
dobin contrib/hgk
python_foreach_impl python_doscript contrib/hg-ssh

if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/$f || die
done

dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?

insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}

src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
#rm -f test-doctest* # doctest always fails with python 2.5.x
rm -f test-largefiles* # tends to time out

popd &>/dev/null || die
distutils-r1_src_test
}

python_test() {
local TEST_DIR

rm -rf "${TMPDIR}"/test
distutils_install_for_testing
cd tests || die
"${PYTHON}" run-tests.py --verbose \
--tmpdir="${TMPDIR}"/test \
--with-hg="${TEST_DIR}"/scripts/hg \
|| die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
use emacs && elisp-site-regen

elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit ffd3522

Please sign in to comment.