Skip to content

Commit

Permalink
dev-ruby/hashie: add 3.5.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
graaff committed Mar 6, 2017
1 parent bf703d6 commit 0028360
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/hashie/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST hashie-2.1.2.gem 34816 SHA256 a9e1e4928bf4f5a5683ea9c7ef29e50fb93f72542f9a9550e205fe33a6568923 SHA512 6f72998710da58a2584939b4e74a114ae54168902020dc16ec5ea0422a91316b84aa6835fffb36a2985634f24ff5b0d01bcdb50134a414a269a4881ebcd728ac WHIRLPOOL 6b67c04ef9dc33a9ffdf25d14440bdd3ce621f1bde9b4eb806de63fa39edc76627f80d10435efc708fc48d24f1450046f33aceb20d76238a0cf8b67ddcf72e78
DIST hashie-3.4.6.gem 62464 SHA256 92ad8b7a3d4eaea3b7c858070a2f4d1a6e1e4dd3072c26bce85f439429f8c9db SHA512 68782865411a21a32e8b81f5d1dd29cdd9e934ffe18a7222a9631df00275cb5ba6c6cfd8b87be510a0ec202e9286660c17e4ead6e35697bb15b8c72b30971797 WHIRLPOOL dce0a10fd45f0dad1c8d1efedc35070a58b490b1183353dc1ee4bcbdb0b0b179aef7fd790487dbaa14459a62de42698c9dcf561b698b5fac7148a5323231fa0f
DIST hashie-3.5.1.gem 66048 SHA256 a68ec7d09a4fb9b34ee04bbbc4ab8b224296cf5404fba154414bc6c565545b61 SHA512 73025d479ec379a7afdea161208f66ae3b7a6c29ac3334fe31ce116edd40476432307950433dde40a86b8ef547313ec3d1ead495ff8425ea957dac3e4287f2f4 WHIRLPOOL 2ab07fc4645aed457b9ea7727b473c5cfecf66996f7e00d6a5f30906af598fa1848b9656b3cdaff5d9c85597d7bb05d3cc4e0355d2c18a05e0edb1aa89d4559a
DIST hashie-3.5.5.gem 71680 SHA256 5c52426ae505bd7b9a68fb5f134855f726b24dd94423e64f0d243c8b125cd551 SHA512 60853f1a0ef274a6cd5b13b6a4085c11d867a0e5a83ebf1f1b210b7635db5789cda515710e2b794e67933f71a579a41b75923e6aff872389b205caf04c4ecc3d WHIRLPOOL 1ffd1af37e14e417b97ccd0872ffc03ed1140be5d6c4f431e5a3e726fc9ed166943c75b9006c032f5839c020c1446822066a04adc03cbdb31e519e6741004155
40 changes: 40 additions & 0 deletions dev-ruby/hashie/hashie-3.5.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem

DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
HOMEPAGE="https://www.mobomo.com/2009/11/hashie-the-hash-toolkit/"

LICENSE="MIT"
SLOT="3"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_bdepend "test? ( dev-ruby/activesupport )"

all_ruby_prepare() {
# Remove bundler and fix one spec that depends on its requires
#rm Gemfile || die
sed -i -e '/[Bb]undler/d' Rakefile || die
sed -e '/pry/ s:^:#:' \
-e '1irequire "pathname"; require "tempfile"' -i spec/spec_helper.rb || die

# Avoid dependency on rspec-pending_for and its dependencies
sed -i -e '/pending_for/ s:^:#:' \
spec/spec_helper.rb \
spec/hashie/mash_spec.rb \
spec/hashie/extensions/strict_key_access_spec.rb || die

# Avoid integration specs to avoid complicated dependencies
rm spec/integration/{omniauth*,rails}/integration_spec.rb || die
}

0 comments on commit 0028360

Please sign in to comment.