Skip to content

Commit

Permalink
dev-libs/libbsd: Bump to version 0.8.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.20, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Jan 30, 2018
1 parent bba8a2f commit 003bf3e
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libbsd/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libbsd-0.8.3.tar.xz 356772 BLAKE2B 7f45f0300e170f02a0c7d4d0e8d3b56b10035af5a0c5749695978fff549c11ae2d13fa8c85e07b059dc30f458d6b0f7fe36129c934070a77ae185f8be0a4e0c3 SHA512 155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f
DIST libbsd-0.8.5.tar.xz 370680 BLAKE2B fd6ec5994d1a13bb46d9edea4c6df8bebfe86f979aebb372f4f22dff50d9127bcd400dbc22209224717576b40b42b288dc69433128258705dd23c3cd752f0fd7 SHA512 bb122862ce8b789e530e9ca1a777d4219db2066ad89fe6028a833a5dc33ac0cd6b553ef5a0a42962d4a594c1f410304fd553b8fab583db539989ec7cca85baf0
DIST libbsd-0.8.6.tar.xz 371112 BLAKE2B adab6c17267e0cff128351efccf5c1225b7dd85dc61dd8168bf212ba5aff8d726fa5be687c041821af9a427ddad9dfcd3630cac9134b9e81c86ab2599e43aef9 SHA512 ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b
DIST libbsd-0.8.7.tar.xz 371772 BLAKE2B aa4aa1c19872edf9e7e6ed270275199366345531a48ee28c25e209f17c5403a22269b91ab1c806cb1b54ba33a8464f4b035fe7ee2bc5dddd0a4fda09c540b058 SHA512 605a14eb5d33c0e45c3bd29e585ebc15832e2ed1efa9356291a0562622168da96db1a20766e9dae8910ea0c1516429f43905edc8d4f2a40a5a341a689d08fcc3
40 changes: 40 additions & 0 deletions dev-libs/libbsd/libbsd-0.8.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit multilib-minimal

DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
HOMEPAGE="https://libbsd.freedesktop.org/wiki/"
SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"

LICENSE="BSD BSD-2 BSD-4 ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"

DEPEND=">=sys-kernel/linux-headers-3.17"
RDEPEND=""

pkg_setup() {
local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
if ! has_version ${CATEGORY}/${PN}; then
if [[ -e ${f} ]]; then
eerror "${m}"
die "${m}"
fi
fi
}

multilib_src_configure() {
# The build system will install libbsd-ctor.a despite of USE="-static-libs"
# which is correct, see:
# https://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
}

multilib_src_install() {
emake DESTDIR="${D}" install
find "${ED}" -name "*.la" -delete || die
}

0 comments on commit 003bf3e

Please sign in to comment.