Skip to content

Commit

Permalink
dev-perl/libwww-perl: Bump to version 6.270.0
Browse files Browse the repository at this point in the history
Upstream:
- fix lw-request -C
- use Getopt::Long in lwp-download
- handle undefined values in ->credentials
- fix lwp-mirror options checks
- update bin scripts to use LWP::VERSION

Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
kentfredric committed Oct 29, 2017
1 parent c2570b7 commit 005cda8
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-perl/libwww-perl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST libwww-perl-6.16.tar.gz 143751 SHA256 daffd268000f92d241f8ae5508ae5616dbd02
DIST libwww-perl-6.24.tar.gz 161940 SHA256 0fcb35f215c6fc84e255835ca6654f7cf2c192364d61433424afc7b37766e75d SHA512 433e62b802f770b1d7c46bbe3a3b16c0e4423ded77b04f394a49340da98a97c74f8332ffc29c1bc0765cdc8277a2fe110a371b6b0be0f9e94ed104273ee0a1d1 WHIRLPOOL 835d2de7f413359b14bde00813d1b8580771bef36f6924e5e900faec6306e25e96b098b3ad73a6c496bc6344ea2dadbc8c5d5231f0ef9032c02746da867dcf4c
DIST libwww-perl-6.25.tar.gz 161902 SHA256 49c0110ef38d27a8963a082cf61ce245447871676b85ec9f2b9b41d6c2f37f33 SHA512 e1e73db3fae08911c9b4d13e9058a7370d1bc5c8274f345fc1c0565aee4eaf97e1da7e7a1456388beaa62adb4bbb9b3226443334c04e2b8f16936225e6b9b949 WHIRLPOOL f7bcef665040709479f399c9cf095e06ccd41327455fd7e61195ac04134d58d8cd16af4e197006a597047f623f0656bb97df6c85d275f53ac93f76bcf7bd8770
DIST libwww-perl-6.26.tar.gz 162165 SHA256 d0c5435275f8638ff36fff8f655ad2ccad1156e66cc47bfacfb9e44fc585b24f SHA512 0af62f1c393b82b2d665f4f460990bb9a446975507cc07148e9e5eebbfbcdd8ea8190dfe1ecb72a229ffa9a5e42edd9eb6c50ac1d3de89ac4681462069a3acb5 WHIRLPOOL 692ce7df77c8d0a4b4067f9e907f85e896819d64daafc1a9404acf4764743b01ce4b3bddc3980816e313f017869d2da62a9224f8d3dabcd915db23f2ab3e20d4
DIST libwww-perl-6.27.tar.gz 163020 SHA256 298f226f0faef4920adeb0317cd774350df50dc5a7e4d6d092d5673e22eab58a SHA512 ceb7df71ef2773752dfa8a46f6e48cfbe7501f543d53ddaf50ee97da2cb21025be4bb32bee62d6f6fa837a7b0726718b3b8470de0b8a9d789e40c16a42b894e7 WHIRLPOOL 4556ab147c852c4987a48027aba7c507e469f2cfecead46e397cd46bfff499db7e60c0c787fc178cc471fe8a94867f24cbdcff96b9342e8b3f273b443b68a86e
70 changes: 70 additions & 0 deletions dev-perl/libwww-perl/libwww-perl-6.270.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=OALDERS
DIST_VERSION=6.27
inherit perl-module

DESCRIPTION="A collection of Perl Modules for the WWW"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ssl test"

RDEPEND="
virtual/perl-Digest-MD5
>=virtual/perl-Encode-2.120.0
dev-perl/Encode-Locale
>=dev-perl/File-Listing-6.0.0
>=dev-perl/HTML-Parser-3.340.0
>=dev-perl/HTTP-Cookies-6.0.0
>=dev-perl/HTTP-Daemon-6.0.0
>=dev-perl/HTTP-Date-6.0.0
>=dev-perl/HTTP-Negotiate-6.0.0
>=dev-perl/HTTP-Message-6.0.0
virtual/perl-IO
>=dev-perl/LWP-MediaTypes-6.0.0
>=virtual/perl-MIME-Base64-2.120.0
>=dev-perl/Net-HTTP-6.70.0
virtual/perl-Scalar-List-Utils
dev-perl/Try-Tiny
>=dev-perl/URI-1.100.0
>=dev-perl/WWW-RobotRules-6.0.0
>=virtual/perl-libnet-1.220.0
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
virtual/perl-Getopt-Long
test? (
virtual/perl-File-Spec
dev-perl/Test-Fatal
dev-perl/Test-RequiresInternet
virtual/perl-Test-Simple
)
"
PDEPEND="
ssl? (
>=dev-perl/LWP-Protocol-https-6.20.0
)
"

src_install() {
perl-module_src_install

# Perform a check to see if the live filesystem is case-INsensitive
# or not. If it is, the symlinks GET, POST and in particular HEAD
# will collide with e.g. head from coreutils. While under Linux
# having a case-INsensitive filesystem is really unusual, most Mac
# OS X users are on it, and also Interix users deal with
# case-INsensitivity since Windows is underneath.

# bash should always be there, if we can find it in capitals, we're
# on a case-INsensitive filesystem.
if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
dosym lwp-request /usr/bin/GET
dosym lwp-request /usr/bin/POST
dosym lwp-request /usr/bin/HEAD
fi
}
3 changes: 0 additions & 3 deletions dev-perl/libwww-perl/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,6 @@
<remote-id type="cpan-module">LWP::ConnCache</remote-id>
<remote-id type="cpan-module">LWP::Debug</remote-id>
<remote-id type="cpan-module">LWP::Debug::TraceHTTP</remote-id>
<remote-id type="cpan-module">LWP::Debug::TraceHTTP::Socket</remote-id>
<remote-id type="cpan-module">LWP::DebugFile</remote-id>
<remote-id type="cpan-module">LWP::MemberMixin</remote-id>
<remote-id type="cpan-module">LWP::Protocol</remote-id>
Expand All @@ -25,8 +24,6 @@
<remote-id type="cpan-module">LWP::Protocol::ftp</remote-id>
<remote-id type="cpan-module">LWP::Protocol::gopher</remote-id>
<remote-id type="cpan-module">LWP::Protocol::http</remote-id>
<remote-id type="cpan-module">LWP::Protocol::http::Socket</remote-id>
<remote-id type="cpan-module">LWP::Protocol::http::SocketMethods</remote-id>
<remote-id type="cpan-module">LWP::Protocol::loopback</remote-id>
<remote-id type="cpan-module">LWP::Protocol::mailto</remote-id>
<remote-id type="cpan-module">LWP::Protocol::nntp</remote-id>
Expand Down

0 comments on commit 005cda8

Please sign in to comment.