Skip to content

Commit

Permalink
version bump (bug #547624)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Michael Sterrett committed Oct 8, 2015
1 parent ea83784 commit 007f1c6
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-action/supertuxkart/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST supertuxkart-0.8.1-src.tar.bz2 229944480 SHA256 335301ae61b0c177be68d5593c65e5b197dc807421f08a8a35740a254cacf8d6 SHA512 1d72230a2cfa6196c6ea6c5464f01d1a0064994c9dafbf5d47c04b5db87e82590fde57a88d5316f2cf6094dcebae5e115b81e5ecc964a29bd669bc83d527d13a WHIRLPOOL 5cf87e57cd5b5d12e4549bf49efb0596e4a1fafa7cba58e366c843e2ebf61c02e5c3471d1591f1231194021cbcb6082829e026616403680fc7ad05bd235b155e
DIST supertuxkart-0.9-src.tar.xz 385780604 SHA256 c0eb24eb49e23ed6d03f4864feb43573e14971c8420bf60c3c654d4e05ff9aa6 SHA512 0876ad8bda49b3a26be82ee60742704608f4aca3e16fc038a06d9aa8dce9389b15fa69b547eca4b4a3c073cea495e7872924732a2e66802987c905348ff25ebb WHIRLPOOL 780c664d418de612fdfa2905dc86f0eddced5b2c0eef60b67931203afd34b418eb254d0270113846a1c51e149acd6a64157263895163fb1016a9a840384eeb51
DIST supertuxkart.png 4435 SHA256 99bc1801cb0514946cb0171d6d5a84484b6dc881edfa7f096b6eb5fea2f28828 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda WHIRLPOOL eef651802a927b451226fc06a682d7dea68b65b05195130ccfc7544165f26f65bda4fc9565e09d6487d02be3cf57880b0c6c257f26587c6bc6d30afc6aa5d3c2
83 changes: 83 additions & 0 deletions games-action/supertuxkart/supertuxkart-0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit gnome2-utils cmake-utils eutils games

DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
HOMEPAGE="http://supertuxkart.sourceforge.net/"
SRC_URI="mirror://sourceforge/supertuxkart/SuperTuxKart/${PV}/${P}-src.tar.xz
mirror://gentoo/${PN}.png"

LICENSE="GPL-3 CC-BY-SA-3.0 CC-BY-2.0 public-domain ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug fribidi wiimote"

# don't unbundle irrlicht and bullet
# both are modified and system versions will break the game
# http://sourceforge.net/tracker/?func=detail&aid=3454889&group_id=74339&atid=540679

RDEPEND="media-libs/libpng:0
media-libs/libvorbis
media-libs/openal
net-misc/curl
sys-libs/zlib
virtual/glu
virtual/jpeg:62
virtual/libintl
virtual/opengl
x11-libs/libX11
x11-libs/libXxf86vm
fribidi? ( dev-libs/fribidi )
wiimote? ( net-wireless/bluez )"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"

src_prepare() {
# inconsistent handling of debug definition
# avoid using Debug build type
if use debug ; then
sed -i \
-e 's/add_definitions(-DNDEBUG)/add_definitions(-DDEBUG)/' \
CMakeLists.txt || die
fi
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_use fribidi FRIBIDI)
$(cmake-utils_use_use wiimote WIIUSE)
-DSTK_INSTALL_BINARY_DIR="${GAMES_BINDIR}"
-DSTK_INSTALL_DATA_DIR="${GAMES_DATADIR}"/${PN}
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
doicon -s 64 "${DISTDIR}"/${PN}.png
dodoc AUTHORS CHANGELOG.md README.md TODO.md
prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 007f1c6

Please sign in to comment.