Skip to content

Commit

Permalink
dev-ros/image_geometry: fix build failure on gcc-6, bug #594406
Browse files Browse the repository at this point in the history
Thanks to Peter Levine who actually fixed the problem upstream!

Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/594406

Package-Manager: portage-2.3.1
  • Loading branch information
Sergei Trofimovich committed Sep 21, 2016
1 parent b12c1b7 commit 009a858
Show file tree
Hide file tree
Showing 3 changed files with 25 additions and 1 deletion.
22 changes: 22 additions & 0 deletions dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
commit ead421b85eeb750cbf7988657015296ed6789bcf
Author: Hodorgasm <[email protected]>
Date: Mon Sep 19 20:27:51 2016 -0400

Fix "stdlib.h: No such file or directory" errors in GCC-6

Including '-isystem /usr/include' breaks building with GCC-6.
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129

diff --git a/image_geometry/CMakeLists.txt b/image_geometry/CMakeLists.txt
index 3c9cb30..e7c9eea 100644
--- a/image_geometry/CMakeLists.txt
+++ b/image_geometry/CMakeLists.txt
@@ -12,7 +12,7 @@ catkin_package(CATKIN_DEPENDS sensor_msgs

catkin_python_setup()

-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
+include_directories(${catkin_INCLUDE_DIRS}
${OpenCV_INCLUDE_DIRS}
)
include_directories(include)
3 changes: 2 additions & 1 deletion dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -21,3 +21,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
PATCHES=("${FILESDIR}"/${PN}-1.12.0-gcc-6.patch)
1 change: 1 addition & 0 deletions dev-ros/image_geometry/image_geometry-1.12.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,3 +21,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
PATCHES=("${FILESDIR}"/${PN}-1.12.0-gcc-6.patch)

0 comments on commit 009a858

Please sign in to comment.