forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/image_geometry: fix build failure on gcc-6, bug #594406
Thanks to Peter Levine who actually fixed the problem upstream! Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/594406 Package-Manager: portage-2.3.1
- Loading branch information
Sergei Trofimovich
committed
Sep 21, 2016
1 parent
b12c1b7
commit 009a858
Showing
3 changed files
with
25 additions
and
1 deletion.
There are no files selected for viewing
22 changes: 22 additions & 0 deletions
22
dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
commit ead421b85eeb750cbf7988657015296ed6789bcf | ||
Author: Hodorgasm <[email protected]> | ||
Date: Mon Sep 19 20:27:51 2016 -0400 | ||
|
||
Fix "stdlib.h: No such file or directory" errors in GCC-6 | ||
|
||
Including '-isystem /usr/include' breaks building with GCC-6. | ||
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129 | ||
|
||
diff --git a/image_geometry/CMakeLists.txt b/image_geometry/CMakeLists.txt | ||
index 3c9cb30..e7c9eea 100644 | ||
--- a/image_geometry/CMakeLists.txt | ||
+++ b/image_geometry/CMakeLists.txt | ||
@@ -12,7 +12,7 @@ catkin_package(CATKIN_DEPENDS sensor_msgs | ||
|
||
catkin_python_setup() | ||
|
||
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS} | ||
+include_directories(${catkin_INCLUDE_DIRS} | ||
${OpenCV_INCLUDE_DIRS} | ||
) | ||
include_directories(include) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters