forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-strategy/wesnoth: Bump to version 1.14.7
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Apr 15, 2019
1 parent
29175a1
commit 009b42f
Showing
2 changed files
with
117 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST wesnoth-1.14.6.tar.gz 491891860 BLAKE2B e15512eefbb7b118ec80a5612c23edce41555fc2869b652d4799bc052f26592852a2b4d1cb76dee3203d8a26c18c4cf9de58dea1ee81403b9881642e902cf2f3 SHA512 f29b78605f5e3c2e9af8884925b43a262d6fce469bf30a4697e2c8bef8a49d0fea17bd6dc1a3e78113a50e6f21e29aedb5ee26ff2b0493371120f8c64b894096 | ||
DIST wesnoth-1.14.7.tar.gz 493837595 BLAKE2B a80781d4f9ec79514c6431c5d45a6cdcb913aabc6329cefe46e7980805d06b60d479110bb6432f2c35a058e551da6b6fa8e0e4f6f1bdf9a159f6329ddb74aa2a SHA512 dbca2b904147f592cc712b11d6414a47bd557d3c677e6b3eacb4fc1ca5420a264f15fdbe45c8c3469ecfb5d1ffa1ac19cceb58c1378aec0e8b4597baa348ca3b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,116 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit cmake-utils user | ||
|
||
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game" | ||
HOMEPAGE="http://www.wesnoth.org | ||
https://github.com/wesnoth/wesnoth" | ||
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~x86-fbsd" | ||
IUSE="dbus dedicated doc fribidi libressl nls openmp server" | ||
|
||
RDEPEND=" | ||
>=dev-libs/boost-1.50:=[nls,threads,icu] | ||
>=media-libs/libsdl2-2.0.4:0[joystick,video,X] | ||
!dedicated? ( | ||
dev-libs/glib:2 | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
>=media-libs/fontconfig-2.4.1 | ||
>=media-libs/sdl2-image-2.0.0[jpeg,png] | ||
>=media-libs/sdl2-mixer-2.0.0[vorbis] | ||
>=media-libs/sdl2-ttf-2.0.12 | ||
media-libs/libvorbis | ||
>=x11-libs/pango-1.22.0 | ||
>=x11-libs/cairo-1.10.0 | ||
sys-libs/readline:0= | ||
dbus? ( sys-apps/dbus ) | ||
fribidi? ( dev-libs/fribidi ) | ||
)" | ||
DEPEND="${RDEPEND} | ||
x11-libs/libX11 | ||
" | ||
BDEPEND=" | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
|
||
pkg_setup() { | ||
if use openmp; then | ||
tc-has-openmp || die "Please switch to an openmp compatible compiler" | ||
fi | ||
|
||
enewgroup ${PN} | ||
enewuser ${PN} -1 /bin/bash -1 ${PN} | ||
} | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
|
||
if ! use doc ; then | ||
sed -i \ | ||
-e '/manual/d' \ | ||
doc/CMakeLists.txt || die | ||
fi | ||
|
||
# respect LINGUAS (bug #483316) | ||
if [[ ${LINGUAS+set} ]] ; then | ||
local lang langs=() | ||
for lang in $(cat po/LINGUAS) ; do | ||
has ${lang} ${LINGUAS} && langs+=( ${lang} ) | ||
done | ||
echo "${langs[@]}" > po/LINGUAS || die | ||
fi | ||
} | ||
|
||
src_configure() { | ||
filter-flags -ftracer -fomit-frame-pointer | ||
if [[ $(gcc-major-version) -eq 3 ]] ; then | ||
filter-flags -fstack-protector | ||
append-flags -fno-stack-protector | ||
fi | ||
|
||
# Work around eclass | ||
append-flags -UNDEBUG | ||
|
||
if use dedicated || use server ; then | ||
mycmakeargs=( | ||
-DENABLE_CAMPAIGN_SERVER="ON" | ||
-DENABLE_SERVER="ON" | ||
-DSERVER_UID="${PN}" | ||
-DSERVER_GID="${PN}" | ||
-DFIFO_DIR="/run/wesnothd" | ||
) | ||
else | ||
mycmakeargs=( | ||
-DENABLE_CAMPAIGN_SERVER="OFF" | ||
-DENABLE_SERVER="OFF" | ||
) | ||
fi | ||
mycmakeargs+=( | ||
-Wno-dev | ||
-DENABLE_GAME="$(usex !dedicated)" | ||
-DENABLE_DESKTOP_ENTRY="$(usex !dedicated)" | ||
-DENABLE_NLS="$(usex nls)" | ||
-DENABLE_NOTIFICATIONS="$(usex dbus)" | ||
-DENABLE_FRIBIDI="$(usex fribidi)" | ||
-DENABLE_OMP="$(usex openmp)" | ||
-DENABLE_STRICT_COMPILATION="OFF" | ||
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
local DOCS=( README.md changelog.md ) | ||
cmake-utils_src_install | ||
if use dedicated || use server; then | ||
rmdir "${ED}/run/wesnothd" || die | ||
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd | ||
fi | ||
} |