forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Closes: https://bugs.gentoo.org/706274 Bug: https://bugs.gentoo.org/799695 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <[email protected]> Closes: gentoo#21497 Signed-off-by: Miroslav Šulc <[email protected]>
- Loading branch information
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gson-parent-2.7.tar.gz 437390 BLAKE2B 596331eb829797ecb172c55bef3bca0710c1461f504d1ff6170f332c3a77fbe8cf79b85b8ca16867040b86c46d6dcef09b0bf29d213fa82dfb911feeeeff57eb SHA512 663365566234bff0a94eac6ad4cd6e772b8fd542af2cccba2c2f75081935247eebf1a2502d5ce5dd0a0e75e140e17a689880a3aa04fa7c47a1e7bc834edd415e | ||
DIST gson-parent-2.8.7.tar.gz 391617 BLAKE2B 2c0fa3927d44c4a5c961518955dfbe6fee60dd61026002d0152d25d6f22dd4ac08b4323256af1053d0f17ef5d9f2a2a3ee86cedebd52a112d258e8c8c37e545d SHA512 044032b24ec1198d054807ccbfd91301307992b6e7d03a2e8578be79a2cdb28ba0ba57a954f11ad43022ec696c1522d242ed6b1045f831c9a370e0621e674fe0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
# Skeleton command: | ||
# java-ebuilder --generate-ebuild --workdir . --pom gson/pom.xml --download-uri https://github.com/google/gson/archive/gson-parent-2.8.7.tar.gz --slot 2.6 --keywords "~amd64 ~ppc64 ~x86" --ebuild gson-2.8.7.ebuild | ||
|
||
EAPI=7 | ||
|
||
JAVA_PKG_IUSE="doc source test" | ||
MAVEN_ID="com.google.code.gson:gson:2.8.7" | ||
JAVA_TESTING_FRAMEWORKS="junit-4" | ||
|
||
inherit java-pkg-2 java-pkg-simple | ||
|
||
DESCRIPTION="Gson JSON library" | ||
HOMEPAGE="https://github.com/google/gson/gson" | ||
SRC_URI="https://github.com/google/${PN}/archive/${PN}-parent-${PV}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="2.6" | ||
KEYWORDS="~amd64 ~ppc64 ~x86" | ||
|
||
DEPEND=">=virtual/jdk-1.8:*" | ||
RDEPEND=">=virtual/jre-1.8:*" | ||
|
||
S="${WORKDIR}/${PN}-${PN}-parent-${PV}/${PN}" | ||
|
||
JAVA_SRC_DIR=( "src/main/java" "src/main/java-templates" ) | ||
|
||
JAVA_TEST_GENTOO_CLASSPATH="junit-4" | ||
JAVA_TEST_SRC_DIR="src/test/java" | ||
JAVA_TEST_EXCLUDES=( | ||
# Tests run: 1063, Failures: 3 | ||
"com.google.gson.functional.GsonVersionDiagnosticsTest" | ||
"com.google.gson.internal.GsonBuildConfigTest" | ||
) |