Skip to content

Commit

Permalink
app-doc/zeal: Bump version to 0.6.1, change default settings
Browse files Browse the repository at this point in the history
Introduce patch to disable the internal update checker.

Signed-off-by: Henning Schild <[email protected]>
Signed-off-by: Ole Reifschneider <[email protected]>
  • Loading branch information
henning-schild authored and Tranquility committed May 30, 2019
1 parent b70da69 commit 00ac609
Show file tree
Hide file tree
Showing 4 changed files with 161 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/zeal/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST zeal-0.4.0.tar.gz 1049326 BLAKE2B b3007dad0ed280954b05464bc107fa51c603d79607acd42ab85bc745d0590bdaed740edac75dac91e0d0da34b5966eb96815e8250a3b68041cb5a8e0389676fc SHA512 fd1e7cd71469e40914b713c10057b3f3d1d2ae9808d296ca01ceb43941b6e7d6754a4f21edf43a594b1c3ebcab20728812db1bdffda6bc78ee49a1d4faaf9627
DIST zeal-0.6.0.tar.gz 1062223 BLAKE2B 691525380dcefa03a1ed94cf0651f16e4e630aef820beed612a4412d8cdef39de25d2cacb84a76b5f7d03b9c3833fbcd60e463722bd7f9c3e147e5e72037211c SHA512 453841cdbab405a6c3842818b0d18b93d3ee8ad299386c25f63986e04674dbd437665e1913a03f0d94944004a619ea18d218de969c487e68e06a205e0edc1d3a
DIST zeal-0.6.1.tar.gz 1063963 BLAKE2B 72f38aac8275cea8da214962b568ff3f634c6c8499a73f506a6b63d947f87bb0b13bf6a0821d7803ccf09689744a79ebf8659ebe1d6ae07863662cb6a017c5ee SHA512 5b1a129980000c0fc8516e2c7d6c4a8de4adde7054ff8d9635e3be35441ad3ef0539746bbe1ca8abce7e6fb3d20c825b57661c3f8cd059ef1480db65ff81f3d9
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
From b08ff87378dab3e6255864d2749e17b71210e7bd Mon Sep 17 00:00:00 2001
From: Henning Schild <[email protected]>
Date: Sat, 9 Mar 2019 16:35:52 +0100
Subject: [PATCH] libs: enforce static linking of internal libs

Since the application binary is the only file installed and the libs are
not used by anyone else, make sure they are always static. Otherwise
cmake can make them shared and those shared libs will be missing after
install.

Signed-off-by: Henning Schild <[email protected]>
---
src/libs/core/CMakeLists.txt | 2 +-
src/libs/registry/CMakeLists.txt | 2 +-
src/libs/ui/CMakeLists.txt | 2 +-
src/libs/ui/qxtglobalshortcut/CMakeLists.txt | 2 +-
src/libs/util/CMakeLists.txt | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/src/libs/core/CMakeLists.txt b/src/libs/core/CMakeLists.txt
index cd212bb..3bd7371 100644
--- a/src/libs/core/CMakeLists.txt
+++ b/src/libs/core/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_library(Core
+add_library(Core STATIC
application.cpp
applicationsingleton.cpp
extractor.cpp
diff --git a/src/libs/registry/CMakeLists.txt b/src/libs/registry/CMakeLists.txt
index 3372711..977919d 100644
--- a/src/libs/registry/CMakeLists.txt
+++ b/src/libs/registry/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_library(Registry
+add_library(Registry STATIC
cancellationtoken.h
docset.cpp
docsetmetadata.cpp
diff --git a/src/libs/ui/CMakeLists.txt b/src/libs/ui/CMakeLists.txt
index 1fe12ef..27a4877 100644
--- a/src/libs/ui/CMakeLists.txt
+++ b/src/libs/ui/CMakeLists.txt
@@ -16,7 +16,7 @@ set(Ui_FORMS
settingsdialog.ui
)

-add_library(Ui
+add_library(Ui STATIC
aboutdialog.cpp
docsetlistitemdelegate.cpp
docsetsdialog.cpp
diff --git a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
index 8b1b0ef..1776839 100644
--- a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
+++ b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
@@ -19,7 +19,7 @@ elseif(WIN32)
)
endif()

-add_library(QxtGlobalShortcut ${QxtGlobalShortcut_SOURCES})
+add_library(QxtGlobalShortcut STATIC ${QxtGlobalShortcut_SOURCES})

find_package(Qt5Gui REQUIRED)
target_link_libraries(QxtGlobalShortcut Qt5::Gui)
diff --git a/src/libs/util/CMakeLists.txt b/src/libs/util/CMakeLists.txt
index d4ab871..ad0e9ec 100644
--- a/src/libs/util/CMakeLists.txt
+++ b/src/libs/util/CMakeLists.txt
@@ -1,7 +1,7 @@
# Nothing to moc here, so avoid empty build units.
set(CMAKE_AUTOMOC OFF)

-add_library(Util
+add_library(Util STATIC
plist.cpp
sqlitedatabase.cpp
version.cpp
--
2.19.2

Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 3d499c8391e36b7fb1780815d04e533f26333145 Mon Sep 17 00:00:00 2001
From: Henning Schild <[email protected]>
Date: Sat, 9 Mar 2019 10:29:54 +0100
Subject: [PATCH 2/2] settings: disable checking for updates by default

Signed-off-by: Henning Schild <[email protected]>
---
src/libs/core/settings.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/libs/core/settings.cpp b/src/libs/core/settings.cpp
index 8922bc4..549ddff 100644
--- a/src/libs/core/settings.cpp
+++ b/src/libs/core/settings.cpp
@@ -72,7 +72,7 @@ void Settings::load()

// TODO: Put everything in groups
startMinimized = settings->value(QStringLiteral("start_minimized"), false).toBool();
- checkForUpdate = settings->value(QStringLiteral("check_for_update"), true).toBool();
+ checkForUpdate = settings->value(QStringLiteral("check_for_update"), false).toBool();

showSystrayIcon = settings->value(QStringLiteral("show_systray_icon"), true).toBool();
minimizeToSystray = settings->value(QStringLiteral("minimize_to_systray"), false).toBool();
--
2.19.2

53 changes: 53 additions & 0 deletions app-doc/zeal/zeal-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils xdg-utils

DESCRIPTION="Offline documentation browser inspired by Dash"
HOMEPAGE="https://zealdocs.org/"
SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="vanilla"

DEPEND="
app-arch/libarchive
dev-qt/qtconcurrent:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsql:5[sqlite]
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
kde-frameworks/extra-cmake-modules:5
>=x11-libs/xcb-util-keysyms-0.3.9
"

RDEPEND="
${DEPEND}
x11-themes/hicolor-icon-theme
"

src_prepare() {
default
eapply "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
if ! use vanilla; then
eapply "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch"
fi
cmake-utils_src_prepare
}

pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 00ac609

Please sign in to comment.