forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-lisp/clozurecl: fix compilation on x86 with 17.0 profile
Suggested-by: Sergei Trofimovich <[email protected]> Closes: https://bugs.gentoo.org/672454 Signed-off-by: Andrey Grozin <[email protected]> Package-Manager: Portage-2.3.41, Repoman-2.3.9
- Loading branch information
Andrey Grozin
committed
Dec 9, 2018
1 parent
6854629
commit 01277b4
Showing
2 changed files
with
9 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
--- a/lisp-kernel/linuxx8632/Makefile | ||
+++ b/lisp-kernel/linuxx8632/Makefile | ||
@@ -76,3 +76,3 @@ USE_LINK_SCRIPT = # -T $(LINK_SCRIPT) | ||
../../lx86cl: $(KSPOBJ) $(KERNELOBJ) $(DEBUGOBJ) Makefile $(LINK_SCRIPT) | ||
- $(CC) -m32 $(CDEBUG) -Wl,--export-dynamic $(HASH_STYLE) -o $@ $(USE_LINK_SCRIPT) $(KSPOBJ) $(KERNELOBJ) $(DEBUGOBJ) -Wl,--no-as-needed $(OSLIBS) | ||
+ $(CC) -m32 $(CDEBUG) -Wl,--export-dynamic $(HASH_STYLE) -no-pie -o $@ $(USE_LINK_SCRIPT) $(KSPOBJ) $(KERNELOBJ) $(DEBUGOBJ) -Wl,--no-as-needed $(OSLIBS) | ||
|