Skip to content

Commit

Permalink
dev-php/libvirt-php: Version bump to 0.5.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Brian Evans committed Jul 2, 2017
1 parent a63845a commit 012b498
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/libvirt-php/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libvirt-php-0.5.2.tar.gz 770816 SHA256 f338caab2bebcce60cd62e3982ec4c1a274ecaf49d03cf7080b45f2f16cd516d SHA512 11844fea8507090826acd81fc7c257ecc3ed9cca10fc785e4d54b98ebd1e213310e379e7ca684c6439d9e2c57800a140fdc9953c6bec72da1959f5ed99e9ef31 WHIRLPOOL 19bde6afd0ef824557048d9f00aa1dd34f7138408326653e49c04a25e514575d1c2d92c462a8a9f40048ae2af7b2e46a27b66561cddf21fb8f28c294085700f5
DIST libvirt-php-0.5.3.tar.gz 778604 SHA256 6cf9a5aa855cf973e4280c890d9da88a2a26a1e5a3c8bb555f885391467f85cf SHA512 b4cbfd8840d8f114fde762b5d6ada155ebdb231b554e28e8526a7af45a802a18f28e90fa52f3d7ca9f616996fe0a8289b70c2d14dca51a52a7bf8a501c3ff44f WHIRLPOOL fc379e7a216e7846dd6711816f19fac8497f67bee69fe66b904b86d40cc7064d941338941d6bb48e13d4fb1e0a8bff6421831c538a66f5b36556fff838d7f598
12 changes: 12 additions & 0 deletions dev-php/libvirt-php/files/remove-imagick-check.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -aurN a/configure.ac b/configure.ac
--- a/configure.ac 2017-05-11 05:28:41.000000000 -0400
+++ b/configure.ac 2017-07-01 21:46:17.636849810 -0400
@@ -172,8 +172,6 @@
LIBVIRT_CHECK_PHP_EXTENSIONDIR
LIBVIRT_CHECK_PHP_CONFDIR

-LIBVIRT_CHECK_PHP_EXTENSION([imagick])
-
OS=`uname`
if test "$OS" = "Darwin"; then
WL=-Wl,
68 changes: 68 additions & 0 deletions dev-php/libvirt-php/libvirt-php-0.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_EXT_NAME="libvirt-php"
PHP_EXT_SKIP_PHPIZE="yes"
USE_PHP="php5-6 php7-0 php7-1"

inherit php-ext-source-r3 autotools

DESCRIPTION="PHP bindings for libvirt"
HOMEPAGE="http://libvirt.org/php/"
SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"

RDEPEND="app-emulation/libvirt
dev-libs/libxml2"
DEPEND="${RDEPEND}
dev-libs/libxslt
virtual/pkgconfig
doc? ( app-text/xhtml1 )"

RESTRICT="test"
DOCS=( AUTHORS ChangeLog NEWS README )

src_unpack() {
default

# create the default modules directory to be able
# to use the php-ext-source-r3 eclass to configure/build
ln -s src "${S}/modules"

for slot in $(php_get_slots); do
cp -r "${S}" "${WORKDIR}/${slot}"
done
}

src_prepare() {
# Remove the insane check for pecl-imagick which is only used in examples
# and is not called upon in any build
local slot
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
eapply "${FILESDIR}/remove-imagick-check.patch"
eapply_user
eautoreconf
done
}

src_install() {
local slot
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
insinto "${EXT_DIR}"
doins "src/.libs/${PHP_EXT_NAME}.so"
done
php-ext-source-r3_createinifiles
einstalldocs
if use doc ; then
docinto /usr/share/doc/${PF}/html
dodoc -r docs/*
fi
}

0 comments on commit 012b498

Please sign in to comment.