Skip to content

Commit

Permalink
media-libs/phonon-vlc: 0.10.0 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
a17r committed Feb 24, 2018
1 parent b9422f6 commit 013fee5
Show file tree
Hide file tree
Showing 3 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/phonon-vlc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST phonon-backend-vlc-0.10.0.tar.xz 61080 BLAKE2B 1397bff2791b6baf1de2967aeb5ee1a6d71dcd68cff937bd9d4e2de51d36d8f95db3095a8cbb0786c78b420d3b4a1d0e2e102051cc6458a2267aeea3b2e6aec5 SHA512 cfe2050ac4c9b43fdf33b3cee9d60e5f1e5702aed4b4f14ec915f84578dba08dd5375c2fba6d19817c34197575e29eb9ed5fd816ea753e2bc124d97ea71b0bc8
DIST phonon-backend-vlc-0.9.1.tar.xz 59972 BLAKE2B 79c3b0d2cb21a04446cfe0a5b4bfed20f4c63cf6eb00037b0f0d8a67ff74fc9eab484d9a108a8d6694bb1ed97ac5618ad1813f7bbcd981bca9678b862bdc9eeb SHA512 104a29159541002d4064486b54d02183c32cf87931c205badf44333d9481b0c0e70e6eae7f9d3c558bef977de37f76cc203dc5c15120f4146d64d451992947aa
34 changes: 34 additions & 0 deletions media-libs/phonon-vlc/files/phonon-vlc-0.10.0-pre-vlc-3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
From ea4d78ac3fc01f33bc2c0f3fb4a44a4103196da5 Mon Sep 17 00:00:00 2001
From: Antonio Rojas <[email protected]>
Date: Fri, 23 Feb 2018 21:51:45 +0100
Subject: Fix build with VLC<3

libvlc_title_description_t and libvlc_chapter_description_t are not defined in vlc < 3

Differential Revision: https://phabricator.kde.org/D10775
---
src/mediaplayer.h | 2 ++
1 file changed, 2 insertions(+)

diff --git a/src/mediaplayer.h b/src/mediaplayer.h
index 9d413d4..cd847db 100644
--- a/src/mediaplayer.h
+++ b/src/mediaplayer.h
@@ -62,11 +62,13 @@ private:
unsigned int m_size;
};

+#if (LIBVLC_VERSION_INT >= LIBVLC_VERSION(3, 0, 0, 0))
typedef Descriptions<libvlc_title_description_t> TitleDescriptions;
typedef QSharedPointer<const TitleDescriptions> SharedTitleDescriptions;

typedef Descriptions<libvlc_chapter_description_t> ChapterDescriptions;
typedef QSharedPointer<ChapterDescriptions> SharedChapterDescriptions;
+#endif

class MediaPlayer : public QObject
{
--
cgit v0.11.2


41 changes: 41 additions & 0 deletions media-libs/phonon-vlc/phonon-vlc-0.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PN="phonon-backend-vlc"

if [[ ${PV} != *9999* ]]; then
SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
else
EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
inherit git-r3
fi

inherit cmake-utils

DESCRIPTION="Phonon VLC backend"
HOMEPAGE="https://phonon.kde.org/"

LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
SLOT="0"
IUSE="debug"

RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
>=media-libs/phonon-4.10.0
media-video/vlc:=[dbus,ogg,vorbis]
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"

PATCHES=( "${FILESDIR}/${P}-pre-vlc-3.patch" )

src_configure() {
local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
cmake-utils_src_configure
}

0 comments on commit 013fee5

Please sign in to comment.