Skip to content

Commit

Permalink
dev-python/oslo-messaging: 5.17.3 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
prometheanfire committed Dec 22, 2017
1 parent 7e65c0d commit 01524c3
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-messaging/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST oslo.messaging-5.17.2.tar.gz 306066 BLAKE2B 00b45f6b8557c4221005f99c17c0158f937327e0e866fc7160767b056b1b59c4a7fdfe34411d1cd9b2874b6d86cf9efcbec4f7af9990f0d9cac217c795cdc3bc SHA512 90f60b4813eabf41d03759e12d7a1cbce334169606fac7ab657c3002e01624946cf492d7a1e5984a4d642f64764691da1799eb6ef4e2ce37196651bafc750760
DIST oslo.messaging-5.17.3.tar.gz 306897 BLAKE2B e1a61dcc6a2533c16529f5e8156998cba8834a1f3c3c1fbfd2b2e218bc2fd407b45096af343015e3a887ddb07a09a2313f0bdd128da354022213f229f9b47a35 SHA512 c5f721499d07bb77914e6c2883ceaca145c94809740274b86b80e6ed83123c12a4ebcea05f287bc651f5d08705100840c973965ff80f5ad976b0fb76c2b026f5
DIST oslo.messaging-5.30.1.tar.gz 316794 BLAKE2B a962841520b559fb433fff6ac2cfa884419d1d53d8ae1e99572e5b32ba2f45cbce55bc812891ab0cffb65db765793e020cf42308a53ee199027e192fe5aaa880 SHA512 e59a17a76963681cd96ef63a5f946ad2e4126f80a7fbdb0d1bc48597ad889862c72450fe526b46d3712eaf92b489e1c0020096e825654c7554c382282923b526
DIST oslo.messaging-5.30.2.tar.gz 317883 BLAKE2B 4003de476db2636eae2462cd3aef7bacb911e321c2cb228263482eda7a82361ec4c731872dbaa8394cfdb42759a8c5e200a03b919c0941f74da32498831394b2 SHA512 b4715c73c158414d1b65fd56c6697ff67ce24499e96ca076f8c3d5d93d0b06ca1f9f80fa0de43c5ee0d5e8de221f20b95e077738b026bac6671d1a2ec6128b08
54 changes: 54 additions & 0 deletions dev-python/oslo-messaging/oslo-messaging-5.17.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
HOMEPAGE="https://pypi.python.org/pypi/oslo.messaging"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.messaging/oslo.messaging-${PV}.tar.gz"
S="${WORKDIR}/oslo.messaging-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"

CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/futurist-0.11.0[${PYTHON_USEDEP}]
!~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
!~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.9.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/cachetools-1.1.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.6.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
>=dev-python/py-amqp-1.4.0[${PYTHON_USEDEP}]
<dev-python/py-amqp-2.0.0[${PYTHON_USEDEP}]
>=dev-python/kombu-3.0.25[${PYTHON_USEDEP}]
!~dev-python/kombu-4.0.0[${PYTHON_USEDEP}]
>=dev-python/pika-0.10.0[${PYTHON_USEDEP}]
>=dev-python/pika-pool-0.1.3[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
>=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

0 comments on commit 01524c3

Please sign in to comment.