Skip to content

Commit

Permalink
dev-python/pycairo: version bump to 1.15.3
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Sep 20, 2017
1 parent 9cd5c6c commit 017893f
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pycairo/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST pycairo-1.13.1.tar.gz 123690 SHA256 d8f58de67ddd01eda9e5112de57599b7d0154d7
DIST pycairo-1.15.0.tar.gz 167963 SHA256 b469b782ffabeeeb5973b64ee55e993521f32ac658b24baccbcd3f939c4f44f8 SHA512 e27f1b31225fe6eba7722a412a4eb9c591a3ce4887ba5a7edb738f757efa8372c1e2cd6ecd52386c350bb5058d8fa1806ee1d5ecabc2377d1934ded29b8592c9 WHIRLPOOL fcd5764ba1f71513ae164555eea081f21565c03ebd2a48cf89adfe29b3f7b3bdd364b5b19f403e5ade3109beddfc81bfbcd25666285dec1a2833c11e8559f249
DIST pycairo-1.15.1.tar.gz 175924 SHA256 987d392270247343595d37591f80639ed902fce7e30bd2f944cb1b0a9093553d SHA512 931b6ca704fcae501b7671dd6cd964746951e08b5d09dc7118e3ff5c3c1f8aba9d211efe7867b77bb30f14f4700f888c7ed297ec5e8afca06d3d7327835c8e1f WHIRLPOOL 3d85ebebfab81a9447e4073f00f77ad0dc204f7f18799cec37b1afde50831faaa8fb01a713548917fa6dc80f7a165a4a032c92224cf09c9837b0b6e47e7bb973
DIST pycairo-1.15.2.tar.gz 176051 SHA256 a66f30c457736f682162e7b3a33bc5e8915c0f3b31ef9bdb4edf43c81935c914 SHA512 ce0ee0b1775eac75eaee9eddcd9dda21d99a6327bac55e0d2e15ce3a8a1869e4d44c59eada1725ba3cdda16fac4ce33a7c350ffdae3892dac85c5e70033e3ee1 WHIRLPOOL 89d8f9a97c3cd7d5d1b2360641ff361dfca0f2567d01fdc96035f57f5389f49249976c341ff5995d9af515c52171a1e5d0ab222b07d00e4020579b3d35a08a2a
DIST pycairo-1.15.3.tar.gz 177056 SHA256 8642e36cef66acbfc02760d2b40c716f5f183d073fb063ba28fd29a14044719d SHA512 1fc75d193eacb976f2e5a594aa07409a0f80ccb21921065c1794961143785eed48be1966d2d2d3e2d0428f9b4e956994dd851d21f3c3cb91fbc27b007a901ce8 WHIRLPOOL e9248366c8eb541bc70ad73c9c6eea995a2527d189584a1ec6f6b835fdeae57d1aa63e2deaa9f790042d0670e7d07af8867b111ac107b53befd354c3cfc70ca1
65 changes: 65 additions & 0 deletions dev-python/pycairo/pycairo-1.15.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="Python bindings for the cairo library"
HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"

LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc examples test xcb"

# Note: xpyb is used as the C header, not Python modules
RDEPEND="
>=x11-libs/cairo-1.13.1[svg,xcb?]
"
DEPEND="${RDEPEND}
xcb? ( $(python_gen_cond_dep '>=x11-libs/xpyb-1.3' 'python2*') )
doc? ( dev-python/sphinx )
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
# Fix pkgconfig path
sed -i -e "/libdir =/s:\"lib\":\"$(get_libdir)\":" setup.py || die
distutils-r1_python_prepare_all
}

python_compile() {
local enable_xpyb
python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")

esetup.py build ${enable_xpyb}
}

python_compile_all() {
use doc && emake -C docs
}

python_test() {
local enable_xpyb
python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")

esetup.py test ${enable_xpyb}
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/. )

if use examples; then
dodoc -r examples
fi

distutils-r1_python_install_all
}

0 comments on commit 017893f

Please sign in to comment.