Skip to content

Commit

Permalink
dev-ruby/activesupport: add 5.2.6.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Feb 22, 2022
1 parent 531dee5 commit 01af6e3
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activesupport/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST rails-5.2.6.2.tgz 8840302 BLAKE2B 54c62924252bdbc7df4b07309dc1f96973660db71c68a9b25f8f9e44fb901982cf38242c613a349220ca043ca82984ee740052fc51521a6e1f088d8b77d4f53b SHA512 f639508300258c210253be875066842553487b0ddee2b56c625b7ed99ae5b9d59d62a69181c0910ebc85786d0a5fc1001385f3700fc198d192eccbe753d2e48c
DIST rails-5.2.6.tgz 8841270 BLAKE2B 8e813f376446ef249aa3b48934d3cb5ae125c09c54353cc93557c3bee4f23e47ae7ceffab75d5cbfb691daed85149d9054337b468a0010bc5c7ebb879502396b SHA512 465e017591a9962a2e0dec2eac9669d5f507d0904e9eec50fbc8848d804ba5f1eb3220fd5acc949845f048f59cfc5e43f099707650edf301d6595e70e33888c7
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbdd1ac92c01272296e87b033d0a877a4fc724d3acece0442025ff9906a3e735ae75a8313135f2ffc55be988b38 SHA512 ae71145cc6e2a532271f6fe063347b261a7c6b1153f4978da5fd539b51b356baa555e731b759d9b49c342b2623b30ff9962396346df66d7e97aeca1fa806b333
Expand Down
74 changes: 74 additions & 0 deletions dev-ruby/activesupport/activesupport-5.2.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby25 ruby26"

RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true"

RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eapi7-ver

DESCRIPTION="Utility Classes and Extension to the Standard Library"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
>=dev-ruby/concurrent-ruby-1.0.2:1
dev-ruby/i18n:1
>=dev-ruby/tzinfo-1.1:1
>=dev-ruby/minitest-5.1:5"

# memcache-client, nokogiri, and builder are not strictly
# needed, but there are tests using this code.
ruby_add_bdepend "test? (
>=dev-ruby/dalli-2.2.1
>=dev-ruby/nokogiri-1.4.5
>=dev-ruby/builder-3.1.0
>=dev-ruby/listen-3.0.5:3
dev-ruby/rack
dev-ruby/mocha
)"

all_ruby_prepare() {
# Set the secure permissions that tests expect.
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"

# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' \
-e 's/gemspec/gemspec path: "activesupport"/' \
-e '5igem "builder"; gem "rack"' ../Gemfile || die
rm ../Gemfile.lock || die
sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die

# Avoid test that depends on timezone
sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die

# Avoid tests that seem to trigger race conditions.
rm -f test/evented_file_update_checker_test.rb || die

# Avoid test that generates filename that is too long
sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die

# Avoid tests requiring a live redis running
rm -f test/cache/stores/redis_cache_store_test.rb || die
sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
}

0 comments on commit 01af6e3

Please sign in to comment.