forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-go/coveraggregator: Vendor golang.org/x/tools
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Zac Medico <[email protected]>
- Loading branch information
Showing
2 changed files
with
16 additions
and
7 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST coveraggregator-0_pre20170216.tar.gz 2394 BLAKE2B 0772a6449917a5a0a8ca953223771edbfc156eb49686a3f2f6eea7981ae8a5fb71727bc59d034e657ab4534e8506eaf012f57609fa5036bc1c2e4778ffdd161e SHA512 07eae44813ebce3d06e103a97ae972823880d58392a9520b1ef6a1dbf44aad4ca5bf572a6eee37a69a2a2c215fbd70587d95f181bba2c0bd7f041385ce169a7a | ||
DIST github.com-golang-tools-a911d9008d1f732040244007778232b02ebb2b84.tar.gz 2298164 BLAKE2B 1c47d5f354174578ee376cc0907235b70df8a81b403da26083dd4138e8bbd1064bb62a5481a5079c43af31e71f76d77eb2be23b85571dbe3a2f48ffd7ed161cf SHA512 acce459c8fa32ca7e48163f92fb6e343b0ea8ec6994b98eb7f7326cf09bf194191c00a01c9eb5d055210cc144d5b986a9e554102a31eca4bba9cbedc500ccdf1 |
22 changes: 15 additions & 7 deletions
22
...ator/coveraggregator-0_pre20170216.ebuild → ...r/coveraggregator-0_pre20170216-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,27 +1,35 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit golang-build golang-vcs-snapshot | ||
EAPI=7 | ||
|
||
EGO_VENDOR=( | ||
"golang.org/x/tools a911d9008d1f732040244007778232b02ebb2b84 github.com/golang/tools" | ||
) | ||
|
||
inherit golang-vcs-snapshot | ||
|
||
KEYWORDS="~amd64" | ||
EGO_PN=github.com/chouquette/${PN} | ||
HOMEPAGE="https://github.com/chouquette/coveraggregator" | ||
EGIT_COMMIT="af12d4d73479a1b49a16bbed8e5c182999dd62be" | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz | ||
${EGO_VENDOR_URI}" | ||
DESCRIPTION="Cover profile aggregator for golang" | ||
LICENSE="WTFPL-2" | ||
LICENSE="WTFPL-2 BSD" | ||
RESTRICT="test" | ||
SLOT="0" | ||
IUSE="" | ||
DEPEND="dev-go/go-tools:=" | ||
DEPEND="" | ||
RDEPEND="" | ||
S=${WORKDIR}/${P}/src/${EGO_PN} | ||
|
||
src_compile() { | ||
export -n GOCACHE XDG_CACHE_HOME #681202 | ||
golang-build_src_compile | ||
GOPATH="${WORKDIR}/${P}" go build -v -work -x ${EGO_BUILD_FLAGS} -o ${PN} "${EGO_PN}" || die | ||
} | ||
|
||
src_install() { | ||
dobin ${PN} | ||
dodoc src/${EGO_PN}/README.md | ||
dodoc README.md | ||
} |