forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-control-center: add 6.2.0
Bug: https://bugs.gentoo.org/934783 Signed-off-by: Matthew S. Turnbull <[email protected]> Signed-off-by: Eli Schwartz <[email protected]>
- Loading branch information
1 parent
5898a56
commit 01c9132
Showing
2 changed files
with
113 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST cinnamon-control-center-5.8.2.tar.gz 3820570 BLAKE2B 3bc009e696c7d469b2a2e15aecc62f290e26d08f65400418666e4a5564a3a113107996326e1edec93a45e9cb935ea96946e385376fe7f1b4b1185425bb4d4964 SHA512 b7b726659ca712a81c8b52bf514c8f061f5146a4728a3f2172ac5658b947e3e72c3194513ac815efaa727664e03ce2684d8d491bfcf0f6e91ea4566d832e86a2 | ||
DIST cinnamon-control-center-6.0.0.tar.gz 3821056 BLAKE2B b856e4c258a76aa5e558cca53ac333df81ae135d731a5de65470282e741a95f2c179fbd9f28e8bb26824de5ee1f9b9fcb0143fee1760800149a345085c45f11b SHA512 e49b72590418da63c6db9c4224e6a32f9014bf4a4810e3a89babaa21d211ade135912e7be1a356c57328d85774517e0f696c724e62b2d3581c5f73c8a88cf486 | ||
DIST cinnamon-control-center-6.2.0.tar.gz 3813695 BLAKE2B 4ddc97e600b2643ee16477165171f5251f7004d53524a77ec5d363717b84cec61c5bd83334a6dbb261d6ef40bd927fcdf6ef779953ad549881871f2f0e70471e SHA512 815158d057267956470d858cfb62e527c3655adce08e1f9b928f3d8b8b43ffc15d04ab1b11d5603dc75e7347925067e9627cc199f0328ccacd0421112de3b7b4 |
112 changes: 112 additions & 0 deletions
112
gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,112 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{10..13} ) | ||
|
||
inherit meson gnome2-utils python-any-r1 xdg virtualx | ||
|
||
DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop" | ||
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-control-center" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86" | ||
IUSE="+colord input_devices_wacom +networkmanager +modemmanager systemd test wayland" | ||
REQUIRED_USE="modemmanager? ( networkmanager )" | ||
RESTRICT="test" | ||
|
||
COMMON_DEPEND=" | ||
app-accessibility/at-spi2-core:2 | ||
>=dev-libs/glib-2.44.0:2 | ||
>=gnome-base/libgnomekbd-3.0.0:0= | ||
>=gnome-extra/cinnamon-desktop-6.2:0= | ||
>=gnome-extra/cinnamon-menus-6.2 | ||
media-libs/fontconfig | ||
>=sys-auth/polkit-0.103 | ||
>=sys-power/upower-0.99.8:= | ||
>=x11-libs/gdk-pixbuf-2.23.0:2 | ||
>=x11-libs/gtk+-3.16.0:3[wayland=] | ||
>=dev-libs/libgudev-232 | ||
>=x11-libs/libnotify-0.7.3 | ||
x11-libs/cairo | ||
x11-libs/libX11 | ||
>=x11-libs/libxklavier-5.1:= | ||
x11-libs/pango | ||
colord? ( | ||
>=x11-misc/colord-0.1.14:0= | ||
) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7:= | ||
>=x11-libs/libXi-1.2 | ||
) | ||
networkmanager? ( | ||
>=gnome-extra/nm-applet-1.2.0 | ||
>=net-libs/libnma-1.8.34 | ||
>=net-misc/networkmanager-1.2.0[modemmanager?] | ||
modemmanager? ( | ||
>=net-misc/modemmanager-0.7:= | ||
) | ||
) | ||
" | ||
RDEPEND=" | ||
${COMMON_DEPEND} | ||
x11-themes/adwaita-icon-theme | ||
colord? ( | ||
>=gnome-extra/gnome-color-manager-3 | ||
) | ||
input_devices_wacom? ( | ||
gnome-extra/cinnamon-settings-daemon[input_devices_wacom] | ||
) | ||
systemd? ( | ||
>=sys-apps/systemd-31 | ||
) | ||
!systemd? ( | ||
app-admin/openrc-settingsd | ||
) | ||
" | ||
DEPEND=" | ||
${COMMON_DEPEND} | ||
app-text/iso-codes | ||
x11-base/xorg-proto | ||
" | ||
BDEPEND=" | ||
${PYTHON_DEPS} | ||
dev-util/glib-utils | ||
>=sys-devel/gettext-0.17 | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
default | ||
python_fix_shebang meson_install_schemas.py | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
$(meson_use colord color) | ||
$(meson_use modemmanager) | ||
$(meson_use networkmanager) | ||
$(meson_use input_devices_wacom wacom) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_test() { | ||
virtx meson_src_test | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} |