Skip to content

Commit

Permalink
dev-python/pychroot: version bump to 0.9.18
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Oct 4, 2017
1 parent db3a5a7 commit 01d14e2
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-python/pychroot/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pychroot-0.9.16.tar.gz 31027 SHA256 8bcfde4f045d34181ab6ec869abb6608c1340de4dd15ceac003287ec610d221d SHA512 6e35c7b40ad27d234c855abf1857aa6579583d848b111559de21edfa0bc6987e08d1d122924101e2e9bdf37886591b7291a607ed22cf2c50aa11b32f7ea65495 WHIRLPOOL 234cdd15e1cda4473d061ec03f8be75560785ca53c441750372d34545e6e0a1d068a2bf9f652cc60486793fb294d3af1d68834602ab0e0160e4194a2a0f6a98d
DIST pychroot-0.9.17.tar.gz 32036 SHA256 4556d110ab3270c2eec817c1e9573e14fe851a9034ee45b4d96b2695f812c467 SHA512 d99b3875e72fc8553d29cc87c4a30b714cc5dcfbff717eb79be26b1cb0590a1c7dab8dcf66528b2805e5eb91a7619c4015b08ff2194470d9d41e94d82bc44971 WHIRLPOOL 7790adeaa8d7699e01a79adfc6c51d9bdf40cec03c1609b1446d8c18b0db2002492a36671d4b37e4ac1e51ef347c663a8e91033722dd4276044a6fe6424f9d38
DIST pychroot-0.9.18.tar.gz 32879 SHA256 ec78082c9ea8a30733ac1cf9773431fe118fb4cbeaf1098572c3b8e4e16eb7aa SHA512 59c8750c9ba8d601eca485079c04d4153bba92531dbd30fba0104694e4435d76e65b762b76ef89a6a6f8908dd6054d1d95fe4be74825ac1c5a56e473370dfa41 WHIRLPOOL 6e69c740bbb93ab8e88555e0c7e72ec5e4cde577c6b687055385df0ad7174e992f5a9410e03dd041309e57924fb70b92f14078c665c06d05d6c87571815b29e1
49 changes: 49 additions & 0 deletions dev-python/pychroot/pychroot-0.9.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi

DESCRIPTION="a python library and cli tool that simplify chroot handling"
HOMEPAGE="https://github.com/pkgcore/pychroot"

LICENSE="BSD"
SLOT="0"
IUSE="test"

if [[ ${PV} == *9999 ]]; then
RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
RDEPEND=">=dev-python/snakeoil-0.7.4[${PYTHON_USEDEP}]"
fi

DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/pytest[${PYTHON_USEDEP}]
)"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"

python_compile_all() {
esetup.py build_man
}

python_test() {
esetup.py test
}

python_install_all() {
local DOCS=( NEWS.rst README.rst )
distutils-r1_python_install install_man
distutils-r1_python_install_all
}
2 changes: 1 addition & 1 deletion dev-python/pychroot/pychroot-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,7 +23,7 @@ IUSE="test"
if [[ ${PV} == *9999 ]]; then
RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
RDEPEND=">=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]"
RDEPEND=">=dev-python/snakeoil-0.7.4[${PYTHON_USEDEP}]"
fi

DEPEND="${RDEPEND}
Expand Down

0 comments on commit 01d14e2

Please sign in to comment.