Skip to content

Commit

Permalink
dev-ruby/prawn: USE_RUBY update to ruby32
Browse files Browse the repository at this point in the history
Signed-off-by: Huang Rui <[email protected]>
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
vowstar authored and graaff committed Aug 25, 2023
1 parent c348af6 commit 01d3c58
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions dev-ruby/prawn/prawn-2.4.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_RUBY="ruby31 ruby32"

RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRAINSTALL="data"

RUBY_FAKEGEM_GEMSPEC="prawn.gemspec"

inherit ruby-fakegem

DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
HOMEPAGE="https://prawnpdf.org/"
SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 Ruby )"
SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

ruby_add_rdepend "
=dev-ruby/matrix-0.4*
=dev-ruby/pdf-core-0.9*
>=dev-ruby/ttfunk-1.7:*
"
ruby_add_bdepend "test? ( dev-ruby/coderay
>=dev-ruby/pdf-inspector-1.2.1
>=dev-ruby/pdf-reader-1.4
)"

all_ruby_prepare() {
sed -i -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die

sed -i -e "/[Bb]undler/d" Rakefile spec/spec_helper.rb || die

# Remove test that needs unpackaged dependency
rm -f spec/prawn_manual_spec.rb || die
}

0 comments on commit 01d3c58

Please sign in to comment.