Skip to content

Commit

Permalink
dev-ruby/maxitest: add 2.4.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
graaff committed Jan 3, 2018
1 parent cf4198d commit 020d3e4
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/maxitest/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST maxitest-2.4.0.tar.gz 15370 BLAKE2B 1645e818c06c42590e919f73c581407aa38dc4f1ff58fe06c7a5a734c3570a4342c7952cbf5130ca9db66f081a3e4c5d32ca2166d6ed5937474a3bbc093ab13c SHA512 41fc6e8eaaebad76278e19574c48e5192363ef466327e83cfd5a3490b98d157bb736556cde57c01180a353ac383e583fed6433443e24a5a5fb6159ed9821a323
DIST maxitest-2.4.1.tar.gz 59653 BLAKE2B 8bdaea5ad48d30cef9c07947634b05f6e5cc8f8e74f985321b1878e26cc36680cf6f6c2d069e947342a5f0e2f2346347952e6121198b0b74af31b0d58bef4070 SHA512 b1c1faeda4c670083d3564a0763ccb4005954e018aed4a574fb4ddcba16c943b1da8ae471d8df5aca9c1010a19605d55609186b4ab56c13b033ad67ed6c9eb27
48 changes: 48 additions & 0 deletions dev-ruby/maxitest/maxitest-2.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="Readme.md"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit versionator ruby-fakegem

DESCRIPTION="Minitest + all the features you always wanted"
HOMEPAGE="https://github.com/grosser/maxitest"
SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_rdepend "<dev-ruby/minitest-5.12:5"

ruby_add_bdepend "test? ( dev-ruby/bundler )"

all_ruby_prepare() {
rm -f Gemfile.lock || die
# Remove developer-only gems from the gemspec and avoid git issues
sed -i -e '/\(bump\|wwtd\)/ s:^:#:' \
-e 's/git ls-files/find/' \
${RUBY_FAKEGEM_GEMSPEC} || die
sed -i -e '/byebug/ s:^:#:' Gemfile || die

}

each_ruby_prepare() {
# Use the correct target
sed -i -e '/sh/ s:ruby:'${RUBY}':' \
-e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
spec/maxitest_spec.rb || die
}

each_ruby_test() {
PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
}

0 comments on commit 020d3e4

Please sign in to comment.