Skip to content

Commit

Permalink
net-analyzer/wireshark: Version bump (bug #563096).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
Jeroen Roovers committed Oct 15, 2015
1 parent 24f7c99 commit 024936a
Show file tree
Hide file tree
Showing 3 changed files with 287 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/wireshark/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST wireshark-1.12.7.tar.bz2 29202490 SHA256 c74a1c14e72ce0f198a93d832e71742c7f312cbbe719e5def9ecef176860f92c SHA512 a4012fa56e8b99e5fb072c1fb82c783a547395ddb013a9473858fdf9fa99270313d6059f9ee210d56c00f420bbad9cab30bdd3c45e9ff07d4f5967c18d1d0f38 WHIRLPOOL 84c60871fb1d8022885108c97323a892bc9ee035fc421e1e96b76819291337e8d0026be6c77e62f03582fb854188535e5fceb50eb17830f5b1a3ff69b3474d4c
DIST wireshark-1.12.8.tar.bz2 29216939 SHA256 357e0a4e49525d80cdc740bb16539fcdb526ad38cc2ed6cabedafc9bdee5c7e7 SHA512 24ad130d9d0718e610f7def2a08e976871205032b4b4b5269c3ae54894c4121fa3b21a0bc6e45e9c2a41119f5553416d5c452dadf7b02f17e7803511d33809f5 WHIRLPOOL ede6a80e914c4694df9ef6753b65af09c7efadb7d6e3c193fa30871de9e673dac8f7a1f185c3b6ca0a316601d720e141dbe817af2a3a930ec870a75f67cde5a9
DIST wireshark-1.99.9.tar.bz2 30495072 SHA256 be7ac8f8eb2c08e0e3d62da9f781db0dc5322a9cbcb024d3f86a66a06185e182 SHA512 d08348df7951ddc9c441bf9e80ab7ea281ccb92c7aa837dcae172037ee3486dcefaa28e8286a5e1654404a57bc0e004320f01c32c55af6f771dc20814d322066 WHIRLPOOL 09708dbe954dd72ae7b9295b57bcc420f36a5ae76ba27ace6c50cf85b19f295a2a10ffe3039018d0dbbba3c72cc3b0e4689512511b48a6ec706eab89f549e94c
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
--- a/configure.ac
+++ b/configure.ac
@@ -1536,25 +1536,6 @@
wireshark_man=""
fi

-if test "$have_gtk" = "yes" ; then
- # If we have GTK then add flags for it.
-
- CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
- if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
- ## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
- ## The deprecations in Gtk 3.10 will not be fixed ...
- CPPFLAGS="-DGDK_DISABLE_DEPRECATION_WARNINGS $CPPFLAGS"
- else
- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
- fi
- CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
- if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
- # Enable GSEAL when building with GTK > 2.20
- # (Versions prior to 2.22 lacked some necessary accessors.)
- CPPFLAGS="-DGSEAL_ENABLE $CPPFLAGS"
- fi
-fi
-
# XXX - Is this really necessary? When we build with both Gtk+ and Qt it works...
if test "$use_glib_cflags" = "true"; then
# Use GLIB_CFLAGS
258 changes: 258 additions & 0 deletions net-analyzer/wireshark/wireshark-1.12.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,258 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils fcaps flag-o-matic multilib qmake-utils qt4-r2 user

DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="http://www.wireshark.org/"
SRC_URI="${HOMEPAGE}download/src/all-versions/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="
adns +caps crypt doc doc-pdf geoip +gtk3 ipv6 kerberos lua +netlink +pcap
portaudio +qt4 qt5 sbc selinux smi ssl zlib
"
REQUIRED_USE="
ssl? ( crypt )
?? ( qt4 qt5 )
"

GTK_COMMON_DEPEND="
x11-libs/gdk-pixbuf
x11-libs/pango
x11-misc/xdg-utils
"
CDEPEND="
>=dev-libs/glib-2.14:2
netlink? ( dev-libs/libnl:3 )
adns? ( >=net-dns/c-ares-1.5 )
crypt? ( dev-libs/libgcrypt:0 )
caps? ( sys-libs/libcap )
geoip? ( dev-libs/geoip )
gtk3? (
${GTK_COMMON_DEPEND}
x11-libs/gtk+:3
)
kerberos? ( virtual/krb5 )
lua? ( >=dev-lang/lua-5.1:* )
pcap? ( net-libs/libpcap )
portaudio? ( media-libs/portaudio )
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4[accessibility]
x11-misc/xdg-utils
)
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
x11-misc/xdg-utils
)
sbc? ( media-libs/sbc )
smi? ( net-libs/libsmi )
ssl? ( net-libs/gnutls )
zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
"
# We need perl for `pod2html`. The rest of the perl stuff is to block older
# and broken installs. #455122
DEPEND="
${CDEPEND}
dev-lang/perl
!<virtual/perl-Pod-Simple-3.170
!<perl-core/Pod-Simple-3.170
doc? (
app-doc/doxygen
app-text/asciidoc
dev-libs/libxml2
dev-libs/libxslt
doc-pdf? ( dev-java/fop )
www-client/lynx
)
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
"
RDEPEND="
${CDEPEND}
gtk3? ( virtual/freedesktop-icon-theme )
qt4? ( virtual/freedesktop-icon-theme )
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
"

pkg_setup() {
enewgroup wireshark
}

src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
"${FILESDIR}"/${PN}-1.11.0-oldlibs.patch \
"${FILESDIR}"/${PN}-1.12.8-gtk-deprecated-warnings.patch \
"${FILESDIR}"/${PN}-1.99.0-qt5.patch \
"${FILESDIR}"/${PN}-1.99.1-sbc.patch \
"${FILESDIR}"/${PN}-1.12.5-cross-compile.patch \
"${FILESDIR}"/${PN}-1.99.7-qt-pie.patch \
"${FILESDIR}"/${PN}-1.12.6-rcc.patch

epatch_user

eautoreconf
}

src_configure() {
local myconf

# Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
# --with-ssl to ./configure. (Mimics code from acinclude.m4).
if use kerberos; then
case $(krb5-config --libs) in
*-lcrypto*)
ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
ewarn "Note there are annoying license incompatibilities between the OpenSSL"
ewarn "license and the GPL, so do your check before distributing such package."
myconf+=( "--with-ssl" )
;;
esac
fi

# Enable wireshark binary with any supported GUI toolkit (bug #473188)
if use gtk3 || use qt4 || use qt5; then
myconf+=( "--enable-wireshark" )
else
myconf+=( "--disable-wireshark" )
fi

use qt4 && export QT_MIN_VERSION=4.6.0

if use qt5; then
export QT_MIN_VERSION=5.3.0
append-cxxflags -fPIC -DPIC
fi

# Hack around inability to disable doxygen/fop doc generation
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
use doc-pdf || export ac_cv_prog_HAVE_FOP=false

# dumpcap requires libcap
# --disable-profile-build bugs #215806, #292991, #479602
econf \
$(use_enable ipv6) \
$(use_with adns c-ares) \
$(use_with caps libcap) \
$(use_with crypt gcrypt) \
$(use_with geoip) \
$(use_with gtk3) \
$(use_with kerberos krb5) \
$(use_with lua) \
$(use_with pcap dumpcap-group wireshark) \
$(use_with pcap) \
$(use_with portaudio) \
$(use_with qt4) \
$(use_with qt5) \
$(usex qt4 MOC=$(qt4_get_bindir)/moc '') \
$(usex qt4 RCC=$(qt4_get_bindir)/rcc '') \
$(usex qt4 UIC=$(qt4_get_bindir)/uic '') \
$(usex qt5 MOC=$(qt5_get_bindir)/moc '') \
$(usex qt5 RCC=$(qt5_get_bindir)/rcc '') \
$(usex qt5 UIC=$(qt5_get_bindir)/uic '') \
$(use_with sbc) \
$(use_with smi libsmi) \
$(use_with ssl gnutls) \
$(use_with zlib) \
$(usex netlink --with-libnl=3 --without-libnl) \
--disable-profile-build \
--disable-usr-local \
--disable-warnings-as-errors \
--sysconfdir="${EPREFIX}"/etc/wireshark \
--without-adns \
${myconf[@]}
}

src_compile() {
default
if use doc; then
use doc-pdf && addpredict "/root/.java"
emake -j1 -C docbook
fi
}

src_install() {
default
if use doc; then
dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
if use doc-pdf; then
insinto /usr/share/doc/${PF}/pdf/
doins docbook/{{developer,user}-guide,release-notes}-{a4,us}.pdf
fi
fi

# FAQ is not required as is installed from help/faq.txt
dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
doc/{randpkt.txt,README*}

# install headers
local wsheader
for wsheader in \
color.h \
config.h \
epan/*.h \
epan/crypt/*.h \
epan/dfilter/*.h \
epan/dissectors/*.h \
epan/ftypes/*.h \
epan/wmem/*.h \
register.h \
wiretap/*.h \
ws_symbol_export.h \
wsutil/*.h
do
insinto /usr/include/wireshark/$( dirname ${wsheader} )
doins ${wsheader}
done

#with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
insinto /usr/include/wiretap
doins wiretap/wtap.h

if use gtk3 || use qt4 || use qt5; then
local c d
for c in hi lo; do
for d in 16 32 48; do
insinto /usr/share/icons/${c}color/${d}x${d}/apps
newins image/${c}${d}-app-wireshark.png wireshark.png
done
done
fi

if use gtk3; then
domenu wireshark.desktop
fi

if use qt4 || use qt5; then
sed -e '/Exec=/s|wireshark|&-qt|g' wireshark.desktop > wireshark-qt.desktop || die
domenu wireshark-qt.desktop
fi

prune_libtool_files
}

pkg_postinst() {
# Add group for users allowed to sniff.
enewgroup wireshark

if use pcap; then
fcaps -o 0 -g wireshark -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap
fi

ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
ewarn "add yourself to the wireshark group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}

0 comments on commit 024936a

Please sign in to comment.