Skip to content

Commit

Permalink
media-radio/tucnak: Initial commit.
Browse files Browse the repository at this point in the history
Newer replacement for media-radio/tucnak2

Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
dl1jbe committed Oct 13, 2017
1 parent 1d1d6e3 commit 0296ca7
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-radio/tucnak/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST tucnak-4.11.tar.gz 3517554 SHA256 0aa1661a2a65d43218e9e17a373078efa417cabeeacfe25fa15f9c2840567946 SHA512 510c13b181f2417e7fddfd13d808288624bfbf3c0e26cab712a7401d24e53432ad4a270a43f8224a75359a2a31ea3f4d7992583bee8188292ed7d8bc5ad8e8a0 WHIRLPOOL ffcee657fc4096c2241d50a50d56c66c1f42c01ef76547568d2b971b10d3b24ebde89ea349a9c20d8009418df8647fb3a90724aec76fe42747e42d0847f9a456
12 changes: 12 additions & 0 deletions media-radio/tucnak/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Thomas Beierlein</name>
</maintainer>
<use>
<flag name="hamlib">Enables support by the Hamlib amateur radio
rig control library to get/set frequency and mode of the ham radio</flag>
</use>
</pkgmetadata>
68 changes: 68 additions & 0 deletions media-radio/tucnak/tucnak-4.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools flag-o-matic multilib

DESCRIPTION="Amateur Radio VHF Contest Logbook"
HOMEPAGE="http://tucnak.nagano.cz"
SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa fftw gpm hamlib suid"

RDEPEND="dev-libs/glib:2
dev-libs/libzia
media-libs/libsndfile
>=media-libs/libsdl-1.2
alsa? ( media-libs/alsa-lib )
fftw? ( sci-libs/fftw:3.0 )
gpm? ( sys-libs/gpm )
hamlib? ( media-libs/hamlib )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
eapply_user
# fix destop file
sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
# fix doc install path
sed -i -e "s/docsdir/# docsdir/" \
-e "s/docs_DATA =/# docs_DATA/" \
-e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
eautoreconf
}

src_configure() {
append-ldflags -L/usr/$(get_libdir)/hamlib
econf $(use_with alsa) \
$(use_with gpm) $(use_with hamlib) \
$(use_with fftw fftw3)
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog doc/NAVOD.pdf
if use suid ; then
fperms 4711 /usr/bin/soundwrapper
fi
}

pkg_postinst() {
elog "In order to use sound with tucnak add yourself to the 'audio' group"
elog "and to key your rig via the parport add yourself to the 'lp' group"
elog ""
elog "tucnak can be used with the following additional packages:"
elog " media-radio/cwdaemon : Morse output via code cwdaemon"
elog " (No need to recompile)"
if use suid ; then
ewarn "You have choosen to install the little helper program 'soundwrapper'"
ewarn "setuid by setting USE=suid. That helper is only needed if you"
ewarn "want to use morse sidetone output via the PC speaker."
ewarn ""
ewarn "While the helper should be safe by design be aware that setting"
ewarn "any program setuid is a security risk."
fi
}

0 comments on commit 0296ca7

Please sign in to comment.