Skip to content

Commit

Permalink
dev-games/recastnavigation: version bump to 1.5.1_p20210305
Browse files Browse the repository at this point in the history
Unbundle catch dep

Closes: https://bugs.gentoo.org/806950
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Alexey Sokolov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
DarthGandalf authored and juippis committed Aug 16, 2021
1 parent 54d9922 commit 02986e4
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-games/recastnavigation/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST recastnavigation-1.5.1_p20200511.tar.gz 1541540 BLAKE2B 3878294247e26421c33019c05a8d70f9ae04ce046d1e503b2df8297e5c390c592e0222c445c9a7798c2e3eb7090b6c32d18b94015dce0a248ab17198d3054dda SHA512 bc48d9195c1ce4422359d850ad422e53c2599ff575b8c7a0ce6b7dc42720d7edd99781a1efa7bee49a00cd4ce6734f34ce9d434421471cb0cbf8e5207bbebebc
DIST recastnavigation-1.5.1_p20210305.tar.gz 1542880 BLAKE2B f1066a48c7269fe67deba17768187522db9c0ece11293a3ff54311a6400cd38f32340985729bb38109bc1262099b44b7bf92974dfeb80c47953e58e6eeab73ea SHA512 7c3a8ce3e38de81eeb31332584896af9f234826c7f7f831eccb36972746c8b528ffde7ae4ee0d25baf814ece030a4b029101e07ea89aacc33c6d44f1ae2cf265
38 changes: 38 additions & 0 deletions dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake flag-o-matic

DESCRIPTION="Navigation mesh construction toolset for games"
HOMEPAGE="https://github.com/recastnavigation/recastnavigation"
MY_COMMIT="c5cbd53024c8a9d8d097a4371215e3342d2fdc87"
SRC_URI="https://github.com/recastnavigation/recastnavigation/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_COMMIT}"

LICENSE="ZLIB"
SLOT="0/1.5.1"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

DEPEND="test? ( dev-cpp/catch )"

src_prepare() {
rm Tests/catch.hpp || die

cmake_src_prepare
}

src_configure() {
append-cppflags "-I${ESYSROOT}/usr/include/catch2"

local mycmakeargs=(
-DRECASTNAVIGATION_DEMO=OFF
-DRECASTNAVIGATION_EXAMPLES=OFF
-DRECASTNAVIGATION_TESTS=$(usex test)
)

cmake_src_configure
}

0 comments on commit 02986e4

Please sign in to comment.