Skip to content

Commit

Permalink
dev-ml/alcotest: initial import; ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
aballier committed Feb 23, 2017
1 parent f6de045 commit 02a8ac3
Show file tree
Hide file tree
Showing 3 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/alcotest/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST alcotest-0.7.2.tar.gz 24781 SHA256 75eac2c9b9c1f9e07d8c4de43ba8e852bd59ef1d7d322cd9c036a075335ef472 SHA512 3448c7d82c200f0cf2ac97f7f49060c350c0719124b24079b5babb48b1d3e0b0508ada0b273e1963dc07dc4cc072b0a589096c39b8b6d8a4adf7e011418dd4a3 WHIRLPOOL d1345d9c3481663fa29d99cf8483bc2e11251a088bd589472eb83f8483b7b3db6130098560de7cb3d00f0741c68c0d0060ae0b602a8f2af51950c0199b0ee612
44 changes: 44 additions & 0 deletions dev-ml/alcotest/alcotest-0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

DESCRIPTION="A lightweight and colourful test framework"
HOMEPAGE="https://github.com/mirage/alcotest/"
SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="test"

RDEPEND="
dev-lang/ocaml:=[ocamlopt]
dev-ml/fmt:=
dev-ml/astring:=
dev-ml/cmdliner:=
dev-ml/result:=
"
DEPEND="${RDEPEND}
dev-ml/opam
dev-ml/topkg
dev-ml/ocamlbuild
dev-ml/findlib"

src_compile() {
ocaml pkg/pkg.ml build --tests $(usex test true false) || die
}

src_test() {
ocaml pkg/pkg.ml test || die
}

src_install() {
opam-installer -i \
--prefix="${ED}/usr" \
--libdir="${D}/$(ocamlc -where)" \
--docdir="${ED}/usr/share/doc/${PF}" \
${PN}.install || die
dodoc CHANGES.md README.md
}
8 changes: 8 additions & 0 deletions dev-ml/alcotest/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo ML Project</name>
</maintainer>
</pkgmetadata>

0 comments on commit 02a8ac3

Please sign in to comment.